Jump to content
OggDude

Another Character Generator

Recommended Posts

 

I'm getting an exception every time I try to add a new motivation. This was working earlier this evening, so it's likely a bug with the new version. I have custom data (descriptions only) that I've had around through several versions. Here's the exception:

 

************** Exception Text **************
System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at System.ThrowHelper.ThrowArgumentOutOfRangeException()
   at SWCharGen.Form1.btnMotiveNew_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at SWCharGen.ImageButton.OnClick(EventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

 

Are you sure you have all of the data installed?  This error is caused by some combination of filters causing either no motivations to show up, or no specific motivations to show up.   In either case, this should be impossible since at least one of the core rulebook sources will always be selected.

 

If you're installing by hand, make sure you remove all files from the installation folder before copying over the new files.

Share this post


Link to post
Share on other sites

When I try to load the program, it gives me an error saying I can't install from this location, it's already installed from another location [paraphrased].

When I click on details, it gives me a bit of script to read, but the gist is that it has something to do with Google Drive.  I don't run the program from my Google Drive, so my guess was something with the updater.  Sure enough, if I start the program with no internet connection, it starts up fine.

I'm not sure if this is something to do with the update specifically or if it's just that too many people are trying to update right now, but I figured I'd mention just in case.

You'll get that error if you used the web install from one location (DropBox or Google Drive), then tried to update your install from the other location.  In any case, just remove (uninstall) your existing installation and do another web install.  The problem should go away.

Share this post


Link to post
Share on other sites

Are you sure you have all of the data installed?  This error is caused by some combination of filters causing either no motivations to show up, or no specific motivations to show up.   In either case, this should be impossible since at least one of the core rulebook sources will always be selected.

 

If you're installing by hand, make sure you remove all files from the installation folder before copying over the new files.

 

 

I'm using the web installer. I use a custom data path that points to a mapped network drive. I'm certain that the data is there because I had it open and working on another PC at the same time it was crashing on the other. Here's a bit more detail:

 

- I was running the tool on 2 PCs that were at version 1.5 (or whatever the last version was)

- I started the tool on a 3rd PC and the web installer auto updated to version 2

- All 3 PCs are pointing to the same data folder. For 1 PC it's on its local HDD and for the other 2 they were using a network mapped drive

 

Creating motivations on the PCs running 1.5 worked fine. The PC running version 2 would crash when clicking the New button. I haven't yet had a chance to double check that the other PCs also throw the same exception after being updated to version 2; I didn't want to have our char gen grind to a halt by updating to a potentially broken version.

 

Is there something specific you want me to try or any more info I can give you?

Share this post


Link to post
Share on other sites

 

Are you sure you have all of the data installed?  This error is caused by some combination of filters causing either no motivations to show up, or no specific motivations to show up.   In either case, this should be impossible since at least one of the core rulebook sources will always be selected.

 

If you're installing by hand, make sure you remove all files from the installation folder before copying over the new files.

 

 

I'm using the web installer. I use a custom data path that points to a mapped network drive. I'm certain that the data is there because I had it open and working on another PC at the same time it was crashing on the other. Here's a bit more detail:

 

- I was running the tool on 2 PCs that were at version 1.5 (or whatever the last version was)

- I started the tool on a 3rd PC and the web installer auto updated to version 2

- All 3 PCs are pointing to the same data folder. For 1 PC it's on its local HDD and for the other 2 they were using a network mapped drive

 

Creating motivations on the PCs running 1.5 worked fine. The PC running version 2 would crash when clicking the New button. I haven't yet had a chance to double check that the other PCs also throw the same exception after being updated to version 2; I didn't want to have our char gen grind to a halt by updating to a potentially broken version.

 

Is there something specific you want me to try or any more info I can give you?

 

Send me the exports for the characters that are giving you problems and I'll see what I can do.

 

Also, try going into options and making sure all sources are selected.

Share this post


Link to post
Share on other sites

There are no characters to send you. This happens with a brand new character. I double checked and all sources are selected. I tried switching my data path back to the default and the exception went away. Next, I tried using the default path but I copied my data from the network folder. The crash came back, so it must be something with my data.

 

This occurs only (as far as I can tell) with the motivations. If I look at them in the data editor, everything looks fine. I'm sure I can probably find a way to get this to work by fiddling with my data but, before that, would you like me to send you my data somehow so you can plug it in yourself to get it up in a debugger?

Share this post


Link to post
Share on other sites

Feature request: Undo/Redo buttons. I like to mess around with different builds and it can get annoying starting from scratch when all i need is to go back a few steps.

 

Thanks

Share this post


Link to post
Share on other sites

There are no characters to send you. This happens with a brand new character. I double checked and all sources are selected. I tried switching my data path back to the default and the exception went away. Next, I tried using the default path but I copied my data from the network folder. The crash came back, so it must be something with my data.

 

This occurs only (as far as I can tell) with the motivations. If I look at them in the data editor, everything looks fine. I'm sure I can probably find a way to get this to work by fiddling with my data but, before that, would you like me to send you my data somehow so you can plug it in yourself to get it up in a debugger?

Then it's probably your data.  Do a backup of DataCustom from the Data Editor and send me the ZIP file.

Share this post


Link to post
Share on other sites

Actually, nevermind :)  It was an issue with the web install.  The new CoreSources.xml file (along with the new imports for the AoR adventures) weren't being put into the correct location.  This should be fixed now.  Just run the program and get the latest version and it should work fine.

Share this post


Link to post
Share on other sites

Hi, After our last session we were able to choose between 15xp or add the specialization tree: recruit. The problem is that i can only "Purchase" the tree and not "add" it. Is there a way to only add it?

 

We also manage to blast asunder a Dark trooper and take his PLASMA SHELL ASSAULT CANNON!!.. awesome. but i can't find it in the SWEchargen. Can i some how make my own or import it somehow?

 

from a rebel scum named Gar-Nak

Share this post


Link to post
Share on other sites

Hi, After our last session we were able to choose between 15xp or add the specialization tree: recruit. The problem is that i can only "Purchase" the tree and not "add" it. Is there a way to only add it?

 

We also manage to blast asunder a Dark trooper and take his PLASMA SHELL ASSAULT CANNON!!.. awesome. but i can't find it in the SWEchargen. Can i some how make my own or import it somehow?

 

from a rebel scum named Gar-Nak

Nope, trees always cost XP :)  If you want the XP, give yourself 15 XP.  If you want the tree, give yourself 20 XP (assuming you only have your starting spec) and purchase it.

 

The assault cannon is added to the Dark Trooper as a custom weapon.  If you want that to be purchasable in your game, just go into the Data Editor and add it as a new weapon.

Share this post


Link to post
Share on other sites

Actually, nevermind :)  It was an issue with the web install.  The new CoreSources.xml file (along with the new imports for the AoR adventures) weren't being put into the correct location.  This should be fixed now.  Just run the program and get the latest version and it should work fine.

It's still not working quite right. If I hit New, it only gives me a choice of Belief, Connections, and Quest. Then, if I click Options, click OK, and then click New, I get the same exception again.

 

All of my sources are selected.

Edited by ddbrown30

Share this post


Link to post
Share on other sites

Yeah, I'm having a similar issue as ddbrown30.  Even did a complete wipe and manual re-install of the entire thing, and still getting the issue of the CharGen program either only shows the core book Motivations, or craps out if I do the "click Options -> click OK" route, without regard to whether I click New to create a new character or I try it for an existing character.

 

If I click to not use "User Data" however, then all the Motivations show up.  I checked my custom data files and there's no modifications made to Motivations that I've made.

Share this post


Link to post
Share on other sites

Yeah, there was another issue with the way specific motivations were being handled.  it's been fixed, but I don't have time right now to do another release.  So, in the mean time, just deselect one source in the list (probably not a core source) and it'll work for you until I get the fix up.

Share this post


Link to post
Share on other sites

I've noticed that your Character Generator doesn't allow you to go to 7 in attributes such as through the use of Cybernetics.

 

Is this intentional or is there a way to get it to go to 7?

Share this post


Link to post
Share on other sites

I... I just noticed the data editor you mentioned... I was adding crap by code. The time I coulda saved.... :blink: Excuse me for a second, I must go to my soundproof room I made for moments like this.

Share this post


Link to post
Share on other sites

I've noticed that your Character Generator doesn't allow you to go to 7 in attributes such as through the use of Cybernetics.

 

Is this intentional or is there a way to get it to go to 7?

You can purchase up to 5, use Dedication to get to 6, then use cybernetics to get to 7.  It's all per CRB.

Share this post


Link to post
Share on other sites

I... I just noticed the data editor you mentioned... I was adding crap by code. The time I coulda saved.... :blink: Excuse me for a second, I must go to my soundproof room I made for moments like this.

If it makes you feel any better, I created probably over half of the data files by hand as well :)  I'll still go in there and make tweaks by hand on occasion.  But... things like vehicles, attachments, weapons... much easier to use the data editor :)

Share this post


Link to post
Share on other sites

 

I've noticed that your Character Generator doesn't allow you to go to 7 in attributes such as through the use of Cybernetics.

 

Is this intentional or is there a way to get it to go to 7?

You can purchase up to 5, use Dedication to get to 6, then use cybernetics to get to 7.  It's all per CRB.

 

 

You're right I'm sorry I wasn't clear, I meant I have 5 brawn, I buy Power Armor and I install the Brawn Mod onto the Power Armor, Shouldn't my Brawn Rating now be 7? However the Character Generator still lists it as 6.

Share this post


Link to post
Share on other sites

How do you add weapon qualities in the data editor?  I am not talking about adding existing qualities to weapons, I am talking about making new qualities.  Am I missing it someplace?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...