Jump to content
OggDude

Another Character Generator

Recommended Posts

On 10/03/2017 at 2:02 PM, Alryon said:

Sorry if this has already been reported, but it's a huge topic and I just started using the generator and following the topic. I noticed an issue while printing droid characters in 1.7: the five or so droid features are printed out as five instances of the same feature (usually the first one). So I get five "Droid: Droids do not need to eat, sleep, etc..." instead of the all five features. I was able to go around it by renaming the features in the editor, so that each feature had a different name in the options list. I encountered a similar issue when creating a subspecies for the droid, but I couldn't go around it this time: one of the features would always print out repeated.

Oh, and I have to congratulate you on this amazing program! It makes playing this game so much easier.

Thanks a lot!

This is still happening in 2.0.0.3. Does anybody else get this problem?

Share this post


Link to post
Share on other sites

Kind of figured you'd need to add it to the build, but with all of the xml . . . 

Side note, was there something new to flag in the template to not increase the damage by brawn? IE in the lightsaber craft template.

Edited by FelixTG

Share this post


Link to post
Share on other sites

I have a strange issue - I tried moving my data folder for the purposes of accessing my characters across both of my laptops - since moving it, I cannot get any of the launchers to work. Nothing happens. Character/data/GM/general launcher, nothing. 

 

When I try to delete all the files, it is unable to delete the GM tools launcher - apparently still in use. I can't find it running anywhere in my processes.

 

So I tried deleting all the other files and just skipping the GM tools launcher, to try and unzip again and replace this strange GM tools launcher. I got this message:

Quote

    D:\RPGs\SWRPG\OggDude's CharGen\SWEotECharGen.zip: Cannot create D:\RPGs\SWRPG\OggDude's CharGen\SWCharGenGMTools.exe
!   Access is denied.

So, it is apparently in use SOMEWHERE but I cannot for the life of me find it.

Edited by Smith606

Share this post


Link to post
Share on other sites
50 minutes ago, Alryon said:

This is still happening in 2.0.0.3. Does anybody else get this problem?

This is what I'm getting for droids:

DroidFeatures.png

You may want to check to see if you customized droids, especially if it was a lot of releases ago (there may have been more recent changes, which you won't get if it's been customized).  If you have, revert it to description only and see if it looks better.

Share this post


Link to post
Share on other sites
13 minutes ago, Smith606 said:

I have a strange issue - I tried moving my data folder for the purposes of accessing my characters across both of my laptops - since moving it, I cannot get any of the launchers to work. Nothing happens. Character/data/GM/general launcher, nothing. 

 

When I try to delete all the files, it is unable to delete the GM tools launcher - apparently still in use. I can't find it running anywhere in my processes.

 

So I tried deleting all the other files and just skipping the GM tools launcher, to try and unzip again and replace this strange GM tools launcher. I got this message:

So, it is apparently in use SOMEWHERE but I cannot for the life of me find it.

By "data folder", you don't mean the actual Data folder that comes in the ZIP file, do you?  That can't be touched.  You can get the directory of your custom data folder from the launcher.

I've had non-related issues where files just become locked for no reason and you just can't delete files.  Generally, it's because the file has actually already been deleted, but Windows is having issues.  Try logging off or rebooting and see if it works.

Share this post


Link to post
Share on other sites
57 minutes ago, FelixTG said:

Kind of figured you'd need to add it to the build, but with all of the xml . . . 

Side note, was there something new to flag in the template to not increase the damage by brawn? IE in the lightsaber craft template.

If you run the weapon editor, you'll see a checkbox at the bottom that says "Do not add Brawn to damage".  The craft templates contain the base form of the item being crafted, so in the case of a weapon, there would be a <Weapon> element that defines what the weapon looks like.  The setting you're looking for is <NoMelee> which, if true, does not add Brawn to melee damage.  This is set to true for all lightsabers in the Weapons.xml file that comes with the apps.

Share this post


Link to post
Share on other sites
10 minutes ago, OggDude said:

By "data folder", you don't mean the actual Data folder that comes in the ZIP file, do you?  That can't be touched.  You can get the directory of your custom data folder from the launcher.

Sorry, I should have been more specific; I'm referring to the App data folder that houses Adversaries, Characters, Encounters etc. 

Restarted my laptop, was able to delete the rogue GM tools launcher. I unzipped again and tried running any of the launchers - still getting the same issue. 

Edit - Tried deleting everything, Including my character files and whatnot then unzipping again. Still not able to launch anything. 

I was actually able to run the latest version though. This only happened after I changed the data file location from the launcher, and then transferred the data across. 

Edited by Smith606

Share this post


Link to post
Share on other sites

Anyone have any thoughts as to why the generator would just stop working in between the verification of no new updates and launching window that allows access to the data editor gm tools and characters on a windows 8.1 operation system.

Share this post


Link to post
Share on other sites
1 hour ago, Smith606 said:

Sorry, I should have been more specific; I'm referring to the App data folder that houses Adversaries, Characters, Encounters etc. 

Restarted my laptop, was able to delete the rogue GM tools launcher. I unzipped again and tried running any of the launchers - still getting the same issue. 

Edit - Tried deleting everything, Including my character files and whatnot then unzipping again. Still not able to launch anything. 

I was actually able to run the latest version though. This only happened after I changed the data file location from the launcher, and then transferred the data across. 

Another thing to try is deleting your cache.  The new version will detect an old cache and replace it with the 4.0 cache, but why tempt fate :)

Share this post


Link to post
Share on other sites
1 hour ago, OggDude said:

If you run the weapon editor, you'll see a checkbox at the bottom that says "Do not add Brawn to damage".  The craft templates contain the base form of the item being crafted, so in the case of a weapon, there would be a <Weapon> element that defines what the weapon looks like.  The setting you're looking for is <NoMelee> which, if true, does not add Brawn to melee damage.  This is set to true for all lightsabers in the Weapons.xml file that comes with the apps.

<NoMelee> did it, thanks.

Share this post


Link to post
Share on other sites
11 minutes ago, FelixTG said:

<NoMelee> did it, thanks.

I did consider adding a template editor, but it's so complicated, plus additional crafting (like lightsabers) will require new improvement types, that it just wasn't worth it.  But, feel free to add whatever you want, if the improvements that are there will do it for you.

And do yourself a favor:  do NOT update the files that come with the app (CraftTemplates, CraftImprovements, and CraftDroidTraits).  You'll want to shoot yourself when you upgrade and they all vaporize :)  Even though they don't have editors, all three files still follow the same guidelines as standard custom data.  So, put your files into your DataCustom directory (or a data set if you want) and decorate each entry with "<Custom>AddedItem</Custom>".  They will magically be combined with the base data.  Just be sure to give each one a unique key.

Edit:  Well, CraftDroidTraits does have an editor.  The other two don't :) 

Edited by OggDude

Share this post


Link to post
Share on other sites

Other than the occasional strange behavior, how is the new version working?  It should be a lot more responsive.  Any problems with the new mechanics, like crafting, companions, mount conversion, etc., etc.?  Are talents doing what they're supposed to?  Any other suggestions for tweaks?

I want to make sure everything is working before diving into 2.0.1 and the other three books, since once I start doing that, we'll have to wait for the next version for fixes.

Share this post


Link to post
Share on other sites
10 hours ago, OggDude said:

Intuitive Improvements can work on any item.  When you purchase it, you'll see a new button in your inventory called "Add HP".  Just select an item (including a crafted item) and click the button.

Ahh, gotcha.  In my case, it is one of the other party members who has Intuitive Improvements, who has used it on my stuff while crafting.

Share this post


Link to post
Share on other sites

It is teasing me that I can finally finish a character that has been using phantom exp for farsight which was added in this update group. Except that the generator wont move past verifying.

Edited by kiranar

Share this post


Link to post
Share on other sites
19 minutes ago, NSIBystander said:

Ahh, gotcha.  In my case, it is one of the other party members who has Intuitive Improvements, who has used it on my stuff while crafting.

The way I handled that was to have both characters in the generator. Then transfer the gear to the person with Intuitive Improvements, add the hard point(s), then transfer the gear back to the original owner. That worked.

Share this post


Link to post
Share on other sites
52 minutes ago, kiranar said:

I been doing the uninstall a lot with it never changing

So, you're using the web install, right?  When you uninstall, are you going to Control Panel/Programs and Features, right-clicking the generator and choosing uninstall?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...