Jump to content
OggDude

Another Character Generator

Recommended Posts

So I've tried updating with the web install on a few computers and it gets to around 70-80% complete and then fails.  I'm trying again with a reinstall of the web version to see if that works better.

I've included the error details below:

ERROR DETAILS
    Following errors were detected during this operation.
    * [3/12/2017 11:33:59 AM] System.Deployment.Application.InvalidDeploymentException (RefDefValidation)
        - Reference in the manifest does not match the identity of the downloaded assembly SWCharGenDataEditor.exe.
        - Source: System.Deployment
        - Stack trace:
            at System.Deployment.Application.DownloadManager.ProcessDownloadedFile(Object sender, DownloadEventArgs e)
            at System.Deployment.Application.FileDownloader.DownloadModifiedEventHandler.Invoke(Object sender, DownloadEventArgs e)
            at System.Deployment.Application.FileDownloader.OnModified()
            at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
            at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
            at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState, X509Certificate2 clientCertificate)
            at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
            at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
            at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
            at System.Deployment.Application.ApplicationActivator.ConsumeUpdatedDeployment(SubscriptionState& subState, ActivationDescription actDesc)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentUpdate(SubscriptionState& subState, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)


Share this post


Link to post
Share on other sites
6 minutes ago, NSIBystander said:

So I've tried updating with the web install on a few computers and it gets to around 70-80% complete and then fails.  I'm trying again with a reinstall of the web version to see if that works better.

I've included the error details below:

 

  Hide contents

 

ERROR DETAILS
    Following errors were detected during this operation.
    * [3/12/2017 11:33:59 AM] System.Deployment.Application.InvalidDeploymentException (RefDefValidation)
        - Reference in the manifest does not match the identity of the downloaded assembly SWCharGenDataEditor.exe.
        - Source: System.Deployment
        - Stack trace:
            at System.Deployment.Application.DownloadManager.ProcessDownloadedFile(Object sender, DownloadEventArgs e)
            at System.Deployment.Application.FileDownloader.DownloadModifiedEventHandler.Invoke(Object sender, DownloadEventArgs e)
            at System.Deployment.Application.FileDownloader.OnModified()
            at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
            at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
            at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState, X509Certificate2 clientCertificate)
            at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
            at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
            at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
            at System.Deployment.Application.ApplicationActivator.ConsumeUpdatedDeployment(SubscriptionState& subState, ActivationDescription actDesc)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentUpdate(SubscriptionState& subState, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

 

 

I tried updating twice and then tried a reinstall. Got this error all 3 times.

Share this post


Link to post
Share on other sites

FWIW, I am getting the same error. The key portion seems to be: "Reference in the manifest does not match the identity of the downloaded assembly SWCharGenDataEditor.exe." Googling leads me to suspect it may be a Visual Studio thing - maybe.

Share this post


Link to post
Share on other sites

I had the same error on a Win 10 PC -- I just downloaded the manual install and unzipped it into the existing CharGen directory, overwriting existing files/pgms: everything's working fine, all data still there (so far).

Share this post


Link to post
Share on other sites

I can't help with the web installer issues (I only use the standalone exe), but on my Windows 10 PC I got some crazy .net error when I first ran it.

As my Data folder is saved into Dropbox, I just had to delete the following folders

C:\Users\%USERNAME%\AppData\Local\SWCharGen
C:\Users\%USERNAME%\AppData\Local\SWCharGenLauncher

It worked straight away after that. I think they must have had all sorts of cruft from previous versions in.

Make sure your Data is backed up. I don't think it's saved there, but I'm not going to swear to it.

 

No luck on the Mac yet. Getting the same errors as before in Mono:

System.TypeInitializationException: The type initializer for 'SWCharGen.EmbeddedFonts' threw an exception. ---> System.EntryPointNotFoundException: AddFontMemResourceEx

Need to poke it more. The launcher ran exactly once (not the first time) and never again. If anyone else gets it working on a Mac, please post here, thanks :)

Share this post


Link to post
Share on other sites

@OggDude Everything appears to be working great.  Previously the 1.8 beta was giving my Windows 10 machine fits and 2.0 is working great.  One question, were you able to get Scars in the game?  Currently I've been working around the limitation by making Scars a custom item in 1.8 but  I was hoping I wouldn't have to in 2.0.  Regardless, the new edition looks great and it working perfectly with my previous version, which has some heavily edited data files, so big thanks.

Share this post


Link to post
Share on other sites

With manual install, ran into null ref issue on a clean install, last call to CharShowInfo from dvgCharacters_SelectionChanged

 

Issue fixed itself after continuing past error, launch splash stayed visible, and imported an existing character. Restarting after that didn't have any more errors.

Share this post


Link to post
Share on other sites

Same re: web installer:

 

Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of https://dl.dropboxusercontent.com/u/26990628/deploy/SWCharGen/SWCharGenLauncher.application resulted in exception. Following failure messages were detected:
        + Reference in the manifest does not match the identity of the downloaded assembly SWCharGenDataEditor.exe.

 

standalone version works fine

Edited by blaked

Share this post


Link to post
Share on other sites
36 minutes ago, TheMongoose said:

I can't help with the web installer issues (I only use the standalone exe), but on my Windows 10 PC I got some crazy .net error when I first ran it.

As my Data folder is saved into Dropbox, I just had to delete the following folders

C:\Users\%USERNAME%\AppData\Local\SWCharGen
C:\Users\%USERNAME%\AppData\Local\SWCharGenLauncher

It worked straight away after that. I think they must have had all sorts of cruft from previous versions in.

Make sure your Data is backed up. I don't think it's saved there, but I'm not going to swear to it.

 

FWIW, I deleted those two folders, and tried the web install again; same error as before. 

Share this post


Link to post
Share on other sites

Was anyone successful running it in mono on a mac? i get errors (which i dont know if it comes from my failed mono or the tool) at start

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'SWCharGen.EmbeddedFonts' threw an exception. ---> System.EntryPointNotFoundException: AddFontMemResourceEx
  at (wrapper managed-to-native) SWCharGen.EmbeddedFonts:AddFontMemResourceEx (byte[],int,intptr,uint&)
  at SWCharGen.EmbeddedFonts.AddFont (System.Byte[] font, System.Boolean addFont, System.String fontName) [0x00058] in <a3e497e44b694c1eb2472d3a84e2bb56>:0 
  at SWCharGen.EmbeddedFonts..cctor () [0x00196] in <a3e497e44b694c1eb2472d3a84e2bb56>:0 
   --- End of inner exception stack trace ---
  at SWCharGen.frmSWCharGenMain..ctor () [0x00018] in <0a11dae786d8460a9b348b9d5944b77a>:0 
  at (wrapper remoting-invoke-with-check) SWCharGen.frmSWCharGenMain:.ctor ()
  at SWCharGen.Program.Main () [0x00006] in <0a11dae786d8460a9b348b9d5944b77a>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'SWCharGen.EmbeddedFonts' threw an exception. ---> System.EntryPointNotFoundException: AddFontMemResourceEx
  at (wrapper managed-to-native) SWCharGen.EmbeddedFonts:AddFontMemResourceEx (byte[],int,intptr,uint&)
  at SWCharGen.EmbeddedFonts.AddFont (System.Byte[] font, System.Boolean addFont, System.String fontName) [0x00058] in <a3e497e44b694c1eb2472d3a84e2bb56>:0 
  at SWCharGen.EmbeddedFonts..cctor () [0x00196] in <a3e497e44b694c1eb2472d3a84e2bb56>:0 
   --- End of inner exception stack trace ---
  at SWCharGen.frmSWCharGenMain..ctor () [0x00018] in <0a11dae786d8460a9b348b9d5944b77a>:0 
  at (wrapper remoting-invoke-with-check) SWCharGen.frmSWCharGenMain:.ctor ()
  at SWCharGen.Program.Main () [0x00006] in <0a11dae786d8460a9b348b9d5944b77a>:0 

 

Edited by Dutzen

Share this post


Link to post
Share on other sites

Give me about 10-15 minutes.  For some reason, all the SQL Server CE files disappeared from my launcher project.  And I needed to reboot as well, since I couldn't remove certain files which I knew could be removed, and that generally means you need to reboot :)  The two issues are probably related.  Anyway, I need to build again and update the web install.  Manual install should still work.

Share this post


Link to post
Share on other sites

OK, I made a 2.0.0.1 build that should now work OK.  Fixed the manifest issue, and it now includes the SQLCE files required for the cache to work.  DropBox is in the process of synchronizing, so give it about 10 minutes and try another web install.  I will be doing the same.

Share this post


Link to post
Share on other sites

Try it again.  It just finished syncing, it probably wasn't done yet when you tried.  It did work for me, but then I got the SQLCE issue, so both should now be fixed.

Share this post


Link to post
Share on other sites
1 minute ago, sevick said:

No I mean I updated again and it's still not working. I get that error.

Do I have to restart my computer?

I just added a new version that should fix the manifest issue.  I also discovered another issue after I installed it.  That should also be taken care of.  The new version should be 2.0.0.1.

Share this post


Link to post
Share on other sites

Not sure how to do the hiding detail things never got it to work but I just got done down loading on this unit this is what I got for an error.

PLATFORM VERSION INFO
    Windows             : 6.3.9600.0 (Win32NT)
    Common Language Runtime     : 4.0.30319.42000
    System.Deployment.dll         : 4.6.1590.0 built by: NETFXREL2
    clr.dll             : 4.6.1590.0 built by: NETFXREL2
    dfdll.dll             : 4.6.1590.0 built by: NETFXREL2
    dfshim.dll             : 6.3.9600.16384 (winblue_rtm.130821-1623)

SOURCES
    Deployment url            : https://dl.dropboxusercontent.com/u/26990628/deploy/SWCharGen/SWCharGenLauncher.application
                        Server        : nginx
    Application url            : https://dl.dropboxusercontent.com/u/26990628/deploy/SWCharGen/Application Files/SWCharGenLauncher_2_0_0_1/SWCharGenLauncher.exe.manifest
                        Server        : nginx

IDENTITIES
    Deployment Identity        : SWCharGenLauncher.application, Version=2.0.0.1, Culture=neutral, PublicKeyToken=0000000000000000, processorArchitecture=x86
    Application Identity        : SWCharGenLauncher.exe, Version=2.0.0.1, Culture=neutral, PublicKeyToken=0000000000000000, processorArchitecture=x86, type=win32

APPLICATION SUMMARY
    * Installable application.

ERROR SUMMARY
    Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of https://dl.dropboxusercontent.com/u/26990628/deploy/SWCharGen/SWCharGenLauncher.application resulted in exception. Following failure messages were detected:
        + File, SWCharGenLauncher.exe, has a different computed hash than specified in manifest.

COMPONENT STORE TRANSACTION FAILURE SUMMARY
    No transaction error was detected.

WARNINGS
    * The manifest for this application does not have a signature. Signature validation will be ignored.
    * The manifest for this application does not have a signature. Signature validation will be ignored.

OPERATION PROGRESS STATUS
    * [3/12/2017 7:49:15 PM] : Activation of https://dl.dropboxusercontent.com/u/26990628/deploy/SWCharGen/SWCharGenLauncher.application has started.
    * [3/12/2017 7:49:16 PM] : Processing of deployment manifest has successfully completed.
    * [3/12/2017 7:49:16 PM] : Installation of the application has started.
    * [3/12/2017 7:49:18 PM] : Processing of application manifest has successfully completed.
    * [3/12/2017 7:49:22 PM] : Found compatible runtime version 4.0.30319.
    * [3/12/2017 7:49:22 PM] : Request of trust and detection of platform is complete.

ERROR DETAILS
    Following errors were detected during this operation.
    * [3/12/2017 8:05:27 PM] System.Deployment.Application.InvalidDeploymentException (HashValidation)
        - File, SWCharGenLauncher.exe, has a different computed hash than specified in manifest.
        - Source: System.Deployment
        - Stack trace:
            at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)
            at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)
            at System.Deployment.Application.ComponentVerifier.VerifyComponents()
            at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
            at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
            at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS
    No transaction information is available.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...