Jump to content
OggDude

Another Character Generator

Recommended Posts

Oggdude,

 

Found a couple of bugs for you. 

Under GM Tools

         Reports

         Selection Options

         "Gears" should be "Gear"

 

OK I had another under reports but I can't reproduce it now.

 

And my third one:

Character Generator

Options

Unselecting a source is only working if you unselect more than one source

 

and I just noticed that Elders has the [h3] tag after it.

You also have an

"Age of Rebellion Core Rulebook" and an

" Age of Rebellion Core Rulebook"

a "Dangerous Covenants"

a "Dangerous Covenants Sourcebook" and

a Dangerous Covenants Sourcebook or page 34 of the Stay on Target Sourcebook"

and you do that again with the Despartate Allies Sourcebook.

 

Actualy it looks like you did it with most of the sourcebooks.  Where you have it with the Name and then the name and sourcebook appended to it.

Share this post


Link to post
Share on other sites

OggDude,

 

I apologize if you answered this earlier in the thread but it's so long I can't find it.

 

That is:  When you come out with a new version, what is the best procedure for updating the software and keep your custom GM Tools, data, and characters?

 

I did it one way with 1.7 but I lost some data.  Can you give me your expert ideas and opinion on the subject?

 

Scott Alden

Share this post


Link to post
Share on other sites

OggDude,

 

I apologize if you answered this earlier in the thread but it's so long I can't find it.

 

That is:  When you come out with a new version, what is the best procedure for updating the software and keep your custom GM Tools, data, and characters?

 

I did it one way with 1.7 but I lost some data.  Can you give me your expert ideas and opinion on the subject?

 

Scott Alden

Install from the web install. It will detect the new version and download and install for you. To do this you need to uninstall the version you have then follow the web install link from his signature. 

Share this post


Link to post
Share on other sites

 

OggDude,

 

I apologize if you answered this earlier in the thread but it's so long I can't find it.

 

That is:  When you come out with a new version, what is the best procedure for updating the software and keep your custom GM Tools, data, and characters?

 

I did it one way with 1.7 but I lost some data.  Can you give me your expert ideas and opinion on the subject?

 

Scott Alden

Install from the web install. It will detect the new version and download and install for you. To do this you need to uninstall the version you have then follow the web install link from his signature. 

 

I'm not following you.  I used the link on the first page of the thread.  It's a web link.  If I uninstall it first then that deletes the whole thing and all my data, no?  I mean... it's a simple zip file no?  Am I missing something?

Share this post


Link to post
Share on other sites

 

 

OggDude,

 

I apologize if you answered this earlier in the thread but it's so long I can't find it.

 

That is:  When you come out with a new version, what is the best procedure for updating the software and keep your custom GM Tools, data, and characters?

 

I did it one way with 1.7 but I lost some data.  Can you give me your expert ideas and opinion on the subject?

 

Scott Alden

Install from the web install. It will detect the new version and download and install for you. To do this you need to uninstall the version you have then follow the web install link from his signature. 

 

I'm not following you.  I used the link on the first page of the thread.  It's a web link.  If I uninstall it first then that deletes the whole thing and all my data, no?  I mean... it's a simple zip file no?  Am I missing something?

 

To do this you need to uninstall the version you have then follow the web install link from his (Oggdudes) signature. 

 

Ogg - question, when are  you going to put in savage spirits in the program? i know someone ask this before but with 329 pages, i don't want to look though to find it (ya i'm lazy)

Share this post


Link to post
Share on other sites

 

 

 

I'm not following you.  I used the link on the first page of the thread.  It's a web link.  If I uninstall it first then that deletes the whole thing and all my data, no?  I mean... it's a simple zip file no?  Am I missing something?

If you lost data, then something went wrong. OggDude stores user data in a separate location than the software installation. The uninstallation or update processes do not touch the user data areas.

Share this post


Link to post
Share on other sites

Oggdude,

 

Found a couple of bugs for you. 

Under GM Tools

         Reports

         Selection Options

         "Gears" should be "Gear"

 

OK I had another under reports but I can't reproduce it now.

 

And my third one:

Character Generator

Options

Unselecting a source is only working if you unselect more than one source

 

and I just noticed that Elders has the [h3] tag after it.

You also have an

"Age of Rebellion Core Rulebook" and an

" Age of Rebellion Core Rulebook"

a "Dangerous Covenants"

a "Dangerous Covenants Sourcebook" and

a Dangerous Covenants Sourcebook or page 34 of the Stay on Target Sourcebook"

and you do that again with the Despartate Allies Sourcebook.

 

Actualy it looks like you did it with most of the sourcebooks.  Where you have it with the Name and then the name and sourcebook appended to it.

Great catch!  Yeah, when I added page numbers to the sources, there were way too many to do by hand (like thousands).  So I wrote a program to do it by breaking down the description to get source and page number.  Obviously, not all of them came out right :)  Plus, I added "Sourcebook" in few places as well.

 

Anyway, those will all be cleaned up in the next release.

Share this post


Link to post
Share on other sites

OggDude,

I apologize if you answered this earlier in the thread but it's so long I can't find it.

That is: When you come out with a new version, what is the best procedure for updating the software and keep your custom GM Tools, data, and characters?

I did it one way with 1.7 but I lost some data. Can you give me your expert ideas and opinion on the subject?

Scott Alden

Install from the web install. It will detect the new version and download and install for you. To do this you need to uninstall the version you have then follow the web install link from his signature.

I'm not following you. I used the link on the first page of the thread. It's a web link. If I uninstall it first then that deletes the whole thing and all my data, no? I mean... it's a simple zip file no? Am I missing something?
No uninstalling will not touch your data. The zip is the harder way. Uninstall. Use the link in Ogg's sig. It is better and auto updates when he releases. Specifically the web install link. Edited by Daeglan

Share this post


Link to post
Share on other sites

Upgraded to 1.7 two characters would not load, and the third would crash the program.
 

Solution.

 

Select Datafolder from Launcher menu

Rename the folder Characters to "Something_Else"

Launch Character Generator

Import Characters from "Something_Else" folder

 

Have fun

Share this post


Link to post
Share on other sites

 

 

 

 

I'm not following you.  I used the link on the first page of the thread.  It's a web link.  If I uninstall it first then that deletes the whole thing and all my data, no?  I mean... it's a simple zip file no?  Am I missing something?

If you lost data, then something went wrong. OggDude stores user data in a separate location than the software installation. The uninstallation or update processes do not touch the user data areas.

 

A few cache refreshes fixed me up... along with data restore... so I think I'm good.

Share this post


Link to post
Share on other sites

 

Oggdude,

 

Found a couple of bugs for you. 

Under GM Tools

         Reports

         Selection Options

         "Gears" should be "Gear"

 

OK I had another under reports but I can't reproduce it now.

 

And my third one:

Character Generator

Options

Unselecting a source is only working if you unselect more than one source

 

and I just noticed that Elders has the [h3] tag after it.

You also have an

"Age of Rebellion Core Rulebook" and an

" Age of Rebellion Core Rulebook"

a "Dangerous Covenants"

a "Dangerous Covenants Sourcebook" and

a Dangerous Covenants Sourcebook or page 34 of the Stay on Target Sourcebook"

and you do that again with the Despartate Allies Sourcebook.

 

Actualy it looks like you did it with most of the sourcebooks.  Where you have it with the Name and then the name and sourcebook appended to it.

Great catch!  Yeah, when I added page numbers to the sources, there were way too many to do by hand (like thousands).  So I wrote a program to do it by breaking down the description to get source and page number.  Obviously, not all of them came out right :)  Plus, I added "Sourcebook" in few places as well.

 

Anyway, those will all be cleaned up in the next release.

 

Oggy,

 

A question about this.  I noticed while going through the XML fils that some of them have

<Sources>

  <Source page=...

</Sources>

 

Some have

<Source page=...

  <Sources />

 

and other just have

<Source page=...

 

Does this matter at all?

Share this post


Link to post
Share on other sites

First off, I LOVE your product. You 

 

However, I am finding a problem with the newest build calculating Defense properly when both weapons and armor have defense.

 

Scenario:

Armor - Defense 1 (Range 1, Melee 1)

Equipped Riot Shield - Defensive 2, Deflection 2

 

Total Defense for this scenario should be 3/3, yet it is only calculating 2/2 (for the shield), ignoring the armor.

 

It appears that it is only taking the higher of the values and using that. I know that defense values from the same source do not stack, but as far as I understand, armor and weapons/shields are considered different categories of Defense (thus the specific Defensive and Deflection properties).

 

Is this a bug, or am I misunderstanding something about how Defense stacks?

Share this post


Link to post
Share on other sites

First off, I LOVE your product. You 

 

However, I am finding a problem with the newest build calculating Defense properly when both weapons and armor have defense.

 

Scenario:

Armor - Defense 1 (Range 1, Melee 1)

Equipped Riot Shield - Defensive 2, Deflection 2

 

Total Defense for this scenario should be 3/3, yet it is only calculating 2/2 (for the shield), ignoring the armor.

 

It appears that it is only taking the higher of the values and using that. I know that defense values from the same source do not stack, but as far as I understand, armor and weapons/shields are considered different categories of Defense (thus the specific Defensive and Deflection properties).

 

Is this a bug, or am I misunderstanding something about how Defense stacks?

The current dev ruling on defense (which has been discussed a few times in this thread not that long ago) is that multiple sources of defense do not stack with one another.  It's been "under review" for quite some time, with no word on when we might get the definitive answer.

 

So as things stand, the program is calculating defense values "correctly" based on the last dev answer.

 

But don't feel bad if you're confused, as a decent chunk of the forum community felt much the same way, especially as the FAQ very much suggested that defense from armor would stack with the Defensive and Deflection qualities.

Share this post


Link to post
Share on other sites

To Oggdude and everyone else.

 

Anyone having editing Talents in the Data Editor for custom data sets? I keep getting unhandled exception on editing some, but not all talents there. Wondering if anyone else has experienced this in 1.7?

 

I have a log of the error, but will be nice and not spam the thread, I can email it to you OD if you would like to take a look.

Share this post


Link to post
Share on other sites

Upgraded to 1.7.0.1 and my saved characters wouldn't show. Followed instructions to transfer data, transferred folder with a lot of entries. Still no characters showing up and the file folder that used to have 70 entries now shows 0. Any ideas how I might be able to retrieve these characters or should I resign myself to the fact that they're gone?

Share this post


Link to post
Share on other sites

Upgraded to 1.7.0.1 and my saved characters wouldn't show. Followed instructions to transfer data, transferred folder with a lot of entries. Still no characters showing up and the file folder that used to have 70 entries now shows 0. Any ideas how I might be able to retrieve these characters or should I resign myself to the fact that they're gone?

Try clearing your cache.

Share this post


Link to post
Share on other sites

 

Upgraded to 1.7.0.1 and my saved characters wouldn't show. Followed instructions to transfer data, transferred folder with a lot of entries. Still no characters showing up and the file folder that used to have 70 entries now shows 0. Any ideas how I might be able to retrieve these characters or should I resign myself to the fact that they're gone?

Try clearing your cache.

 

FYI, from the name "clearing cache" I was worried that it might delete my saved entries... I made a backup and then tried clearing my cache and didn't need to use the backup because clearing the cache does not delete data in your data directory, instead it does what I actually does what I thought it would and removes the fast reload of "working memory" which forces it to reread the saved files from the drive.

 

Also FYI the "data editor" tool has a "backup" button on the front page and it would be a good idea to click it before upgrading in the future, just in case.

Share this post


Link to post
Share on other sites

Oggdude,

 

First of all, LOVE this program!

 

I noticed that the shaped nozzle attachment is listed for just about all, if not all, weapons, and it is supposed to only be available for the ion Thruster Gun.

 

Keep up the great work!

Share this post


Link to post
Share on other sites

 

 

Oggdude,

 

Found a couple of bugs for you. 

Under GM Tools

         Reports

         Selection Options

         "Gears" should be "Gear"

 

OK I had another under reports but I can't reproduce it now.

 

And my third one:

Character Generator

Options

Unselecting a source is only working if you unselect more than one source

 

and I just noticed that Elders has the [h3] tag after it.

You also have an

"Age of Rebellion Core Rulebook" and an

" Age of Rebellion Core Rulebook"

a "Dangerous Covenants"

a "Dangerous Covenants Sourcebook" and

a Dangerous Covenants Sourcebook or page 34 of the Stay on Target Sourcebook"

and you do that again with the Despartate Allies Sourcebook.

 

Actualy it looks like you did it with most of the sourcebooks.  Where you have it with the Name and then the name and sourcebook appended to it.

Great catch!  Yeah, when I added page numbers to the sources, there were way too many to do by hand (like thousands).  So I wrote a program to do it by breaking down the description to get source and page number.  Obviously, not all of them came out right :)  Plus, I added "Sourcebook" in few places as well.

 

Anyway, those will all be cleaned up in the next release.

 

Oggy,

 

A question about this.  I noticed while going through the XML fils that some of them have

<Sources>

  <Source page=...

</Sources>

 

Some have

<Source page=...

  <Sources />

 

and other just have

<Source page=...

 

Does this matter at all?

 

In the beginning, there was one <Source> line for each piece of master data.  Then, FFG started re-publishing stuff in multiple books (like species, weapons, armor, talents, etc).  So, I added <Sources>, which could contain multiple <Source>.  However, I didn't want to break anything, so I kept the old "<Source>" in.  To find all sources, I combined the single with the list.

Share this post


Link to post
Share on other sites

To Oggdude and everyone else.

 

Anyone having editing Talents in the Data Editor for custom data sets? I keep getting unhandled exception on editing some, but not all talents there. Wondering if anyone else has experienced this in 1.7?

 

I have a log of the error, but will be nice and not spam the thread, I can email it to you OD if you would like to take a look.

Let me know which talents are giving you problems and I'll check it out.

Share this post


Link to post
Share on other sites

 

 

Upgraded to 1.7.0.1 and my saved characters wouldn't show. Followed instructions to transfer data, transferred folder with a lot of entries. Still no characters showing up and the file folder that used to have 70 entries now shows 0. Any ideas how I might be able to retrieve these characters or should I resign myself to the fact that they're gone?

Try clearing your cache.

 

FYI, from the name "clearing cache" I was worried that it might delete my saved entries... I made a backup and then tried clearing my cache and didn't need to use the backup because clearing the cache does not delete data in your data directory, instead it does what I actually does what I thought it would and removes the fast reload of "working memory" which forces it to reread the saved files from the drive.

 

Also FYI the "data editor" tool has a "backup" button on the front page and it would be a good idea to click it before upgrading in the future, just in case.

 

Tried the clear cache thing first, and also after the data transfer. Didn't do anything either time. Thanks for the suggestions though. I appreciate it. Seems like maybe backing up the data wouldn't have helped if it just gets erased when transferring anyway.

Share this post


Link to post
Share on other sites

 

To Oggdude and everyone else.

 

Anyone having editing Talents in the Data Editor for custom data sets? I keep getting unhandled exception on editing some, but not all talents there. Wondering if anyone else has experienced this in 1.7?

 

I have a log of the error, but will be nice and not spam the thread, I can email it to you OD if you would like to take a look.

Let me know which talents are giving you problems and I'll check it out.

 

 

Well Traveled is the one that most recently gave me issues. There were a couple others but I can't remember them off the top of my head. Will attempt to mod a few others and see if I get an issue.

 

Just tried Vehicle Combat Training, happened there as well.

Edited by NovaGman

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...