Jump to content
Sign in to follow this  
Qualitypunk

Fang Fighter v2 issues

Recommended Posts

I just opened 2 Fang Fighters. One I got the wings to rotate but when trying the other the connection point to the peg broke off. I've sent a replacement part form off to FFG but it seems odd some wings rotate while others don't.

I know there are problems with the wings being stuck on some models but haven't heard of any actually breaking. Is this common?

Share this post


Link to post
Share on other sites
Just now, Qualitypunk said:

I just opened 2 Fang Fighters. One I got the wings to rotate but when trying the other the connection point to the peg broke off. I've sent a replacement part form off to FFG but it seems odd some wings rotate while others don't.

I know there are problems with the wings being stuck on some models but haven't heard of any actually breaking. Is this common?

I had an entire wing snap off when I was wiggling them to work them loose.

Share this post


Link to post
Share on other sites
Just now, Qualitypunk said:

Did you get a new model or have to glue it together?

A little dab of superglue and it was fine, but I've given up on trying to get the wings to rotate. It snapped off because I was trying to instead not snap the connector peg.

Share this post


Link to post
Share on other sites

I used a hobby knife to loosen the gap between the rotating circle and the end cap. I then removed the end cap. 

Then used the knife on the other side of the rotating circle. Between it and the main body of the fang to loosen that.

Eventually you loosen it so much that the wings can rotate. And you put the end cap back in.

Brute force seemed likely to cause a breakage.

Did this with both my Protectorates. Tried to upload my photos that i sent to my clubmates as a guide. But max size is 0.49mb...

*I used the knife on the underside of the model, so that the minor scratches to the paintwork weren't visible.

Edited by Darth Seridur

Share this post


Link to post
Share on other sites
6 minutes ago, Darth Seridur said:

I used a hobby knife to loosen the gap between the rotating circle and the end cap. I then removed the end cap. 

Then used the knife on the other side of the rotating circle. Between it and the main body of the fang to loosen that.

Eventually you loosen it so much that the wings can rotate. And you put the end cap back in.

Brute force seemed likely to cause a breakage.

Did this with both my Protectorates. Tried to upload my photos that i sent to my clubmates as a guide. But max size is 0.49mb...

*I used the knife on the underside of the model, so that the minor scratches to the paintwork weren't visible.

I have found the little "Insert other media" drop-down in the lower right of the commenting box works better than actually attaching, but that requires you have a URL to use. There's some way to do "attach existing images" but I haven't bothered figuring it out.

 

The "end cap" you're mentioning. Is that the engine section behind the cockpit? If that's not too difficult to remove, then I can try fixing my annoying mismatched Fang.

Share this post


Link to post
Share on other sites

I put my Fangs in the freezer until chilled, which made them easy to slice.

Wait, that's not right.

I put them in the freezer until chilled, which made the paint/glue that was sticky really brittle, and therefore easier to break lose, because it wasn't doing that at all before then.

 

Share this post


Link to post
Share on other sites
15 hours ago, Innese said:

A little dab of superglue and it was fine, but I've given up on trying to get the wings to rotate. It snapped off because I was trying to instead not snap the connector peg.

This.  I didn't break mine, but I gave up for fear I would. 

Share this post


Link to post
Share on other sites

Yeah the paint for them causes the wings to stay locked sonto speak. Brute force is an option that may break the model but others have had luck with heat, cold, a knife, or a few of the above.

The lando falcon with the escape craft had a similar issue for me.

Share this post


Link to post
Share on other sites
5 hours ago, CaptainIxidor said:

I have found the little "Insert other media" drop-down in the lower right of the commenting box works better than actually attaching, but that requires you have a URL to use. There's some way to do "attach existing images" but I haven't bothered figuring it out.

 

The "end cap" you're mentioning. Is that the engine section behind the cockpit? If that's not too difficult to remove, then I can try fixing my annoying mismatched Fang.

Edited the picture massively to just fit the limit. The end cap is the bit i have taken off. That was where i first used the knife. Then used the hobby knife on the other side if the rotating cog as shown in the photo.

20181108_212358.jpg

Share this post


Link to post
Share on other sites
21 minutes ago, Darth Seridur said:

Edited the picture massively to just fit the limit. The end cap is the bit i have taken off. That was where i first used the knife. Then used the hobby knife on the other side if the rotating cog as shown in the photo.

20181108_212358.jpg

Thanks for showing that! Now I'm not sure I can actually fix my problem but at least I have an idea of what it will take to fix it. Hopefully I'm not just imagining that it's not actually level.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...