Jump to content
ffgBrian

Squad Builder Bug Reporting

Recommended Posts

As we continue to work to improve the app experience, the feedback you provide is critical to identifying and addressing issues. If you are experiencing any issues with the Squad Builder, please email xwingsquadbuilder@fantasyflightgames.com with your bug report. To better facilitate these reports, please explain the bug in as much detail as possible, including:

  • Which version of the app the problem is occurring on (1.0.3, 1.0.4, etc)
  • The form of the app the problem is occurring on (Mobile, web)
  • The kind of device you are using (iPhone, Android, computer)

Users who have trouble logging in should also send their asmodee.net username and the email address associated with that account. We will most likely not be able to individually respond to every message, but we will send the reports along to the dev team. Thanks!

Share this post


Link to post
Share on other sites

Do you have any plans to put your bug tracker somewhere public? (Jira, etc)

Or are we just going to inundate your email with the same bug report over and over again? I know a bunch of us reported the card database being broken, for example, but have not yet gotten any indication that you're aware of the problem and fixing it. (Edit: That appears to have been fixed this morning.)

Edited by jftanner

Share this post


Link to post
Share on other sites

Version: 1.1.0

Platform: Android Mobile

Problem: I can't save any squads since 1.1.0 patch. I construct a squad and, after naming it, when I click save nothing happens. If I try to save a squad before naming it I get the can't save a squad that is not named alert. I've tried it with both FO and Scum squads and was unable to save either of them. I've also tried uninstalling and reinstalling the app with no success.

Edited by T70 Driver

Share this post


Link to post
Share on other sites

Not exactly a bug but just a feature poorly implemented. 

In the Custom format when selecting unique upgrades that are across different factions (i.e. Han Solo) there is no way of determining the faction that upgrade is in when selecting to enable/disable that upgrade.

Share this post


Link to post
Share on other sites
There's a bug in the App in spanish that doesn't let us see the points of the list you're building.
The issue is that "Squad points" uses less characters than "Puntos de escuadrón". 12 letters in english and 19 letters in spanish. 
The spanish community is quite upset with the mistake because is quite annoying to build a list and having to save the list > go back to saved squadrons > find the list again > edit everytime you wish to know the total point cost of the squad you're building.
Please put it in the "things to fix in upcoming updates" list.

Share this post


Link to post
Share on other sites

Android Version 1.1.0

On multiple occasions, I've started making a new squad and the name field shows the name of a saved squad I was looking at just a few minutes ago. When I try to save this new squad, it overwrites the one whose name was in the field. I've tried changing the name and it still overwrites the other one. I've also tried exiting and reopening the app, which also doesn't help.

Share this post


Link to post
Share on other sites
On 1/21/2019 at 1:07 PM, Averross said:

Android Version 1.1.0

On multiple occasions, I've started making a new squad and the name field shows the name of a saved squad I was looking at just a few minutes ago. When I try to save this new squad, it overwrites the one whose name was in the field. I've tried changing the name and it still overwrites the other one. I've also tried exiting and reopening the app, which also doesn't help.

I have seen this too on iPhone version 1.1.0 except when I save.  The new squad does not overwrite the old.  However, the rest of the bug has occurred on all previous versions I can think of.

Edited by Tharcas

Share this post


Link to post
Share on other sites

So at this point, when I try to launch the Squad Builder, I get a completely blank black screen 80-90% of the time. I used to use it a fair bit, but because of this (most recent) bug, I pretty much entirely use a 3rd party squad builder now.

Screenshot_20190128-092110.png

Edited by Dr Moneypants
Added picture

Share this post


Link to post
Share on other sites
On 1/21/2019 at 2:07 PM, Averross said:

Android Version 1.1.0

On multiple occasions, I've started making a new squad and the name field shows the name of a saved squad I was looking at just a few minutes ago. When I try to save this new squad, it overwrites the one whose name was in the field. I've tried changing the name and it still overwrites the other one. I've also tried exiting and reopening the app, which also doesn't help.

This has happened to me too.

Share this post


Link to post
Share on other sites

Android version 8.0.0 Samsung Galaxy S7. 

Went into saved squads, tried to edit the name. It let me change the name. I tapped save squad. I went to saved squads. It doesn't change the name. 

This is a simple database record update. How did this make it out of QA. Ridiculous. 

UPDATE:

Previously I had saved the list with a Han Solo Pilot and a Han Solo gunner on the falcon. After removed the Han Solo gunner, it saved with the new name. 

It would have been nice to be presented with a message that said why it wouldn't save. 

Edited by XiliX

Share this post


Link to post
Share on other sites
On 1/21/2019 at 8:07 PM, Averross said:

Android Version 1.1.0

On multiple occasions, I've started making a new squad and the name field shows the name of a saved squad I was looking at just a few minutes ago. When I try to save this new squad, it overwrites the one whose name was in the field. I've tried changing the name and it still overwrites the other one. I've also tried exiting and reopening the app, which also doesn't help.

Go into saved squads and open the squad With the same name as in the name field when trying to create a new squad. Then press save squad. Now the name field will be empty when creating a new squad. (Android)

This problem has been there since day one. It happens fairly often, i honestly thought it had been reported more Times. 

Share this post


Link to post
Share on other sites
Posted (edited)

Version 1.1.1 not updated on my Android. All my hyperspace lists are gone. Still showing as version 1.1.0.

Edited by Rabid Bantha
Added more information.

Share this post


Link to post
Share on other sites
Posted (edited)

As of the release of version 1.1.1, Spare Parts Canisters is not available as a selection, and is missing its card image in the card database.

Edit: It appears to be available only in Extended, despite being listed as available Hyperspace. You also must have an Astromech equipped.

spare-parts.PNG

Edited by pquinn

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...