Jump to content
Julia

SW: IA - APP - Bug Report

Recommended Posts

6 hours ago, Mburnaugh64 said:

I just started the regular campaign after the Jabba update, it crashes every time after the first part when we escape with the transport as soon as the galaxy map comes up it crashes. 

Do you have the 1.4 version released yesterday?

Share this post


Link to post
Share on other sites

Yesterday I was playing and beating Mission 4 (mr Weiss guest star) and made a save as usual. Today I was prepared for the final mission, but I can’t find it, my galaxy map is empty!! The rest is ok: rewards, items... but nothing i n the galaxy.

I have the last update for iPad.

what can I do?? 

:(

Share this post


Link to post
Share on other sites

I'm not sure if it's a bug but since the latest update, after the first mission  (jabba's realm campaign) the armory inventory often contains the dh-17 blaster, dl-44 blaster and the charged pistol, ignoring any other possible weapons.  I've made a few tests with 4 heroes from which one is a melee weapon carrier.  I have all expansions enabled in the collection menu, so I was expecting more variability.

Share this post


Link to post
Share on other sites
On 8/28/2018 at 9:54 AM, Lacustre said:

Yesterday I was playing and beating Mission 4 (mr Weiss guest star) and made a save as usual. Today I was prepared for the final mission, but I can’t find it, my galaxy map is empty!! The rest is ok: rewards, items... but nothing i n the galaxy.

I have the last update for iPad.

what can I do?? 

:(

I know you said you have the latest update, but double-check the version number (latest is version 1.4) if you haven't already.  If it is the most recent version then you may want to send an email to software@fantasyflightgames.com.

 

15 hours ago, IanSolo_FFG said:

I'm not sure if it's a bug but since the latest update, after the first mission  (jabba's realm campaign) the armory inventory often contains the dh-17 blaster, dl-44 blaster and the charged pistol, ignoring any other possible weapons.  I've made a few tests with 4 heroes from which one is a melee weapon carrier.  I have all expansions enabled in the collection menu, so I was expecting more variability.

Hmm... those all came up for me as well (on v1.3 and 1.4).  I did get the vibrosword after the first mission and gaffi stick after the second though.  A lot of items have stayed present after a few missions as well.  I've completed three missions and the Plasma Cell has been available since the first one.  Are you playing on Steam?

Share this post


Link to post
Share on other sites

(If you don't care for an item in the shop, I think by buying it and then selling it you might get it to not show up again... Because in the app you get an equal amount of credits back it can be done easily.)

 

Share this post


Link to post
Share on other sites
1 hour ago, Uninvited Guest said:

Hmm... those all came up for me as well (on v1.3 and 1.4).  I did get the vibrosword after the first mission and gaffi stick after the second though.  A lot of items have stayed present after a few missions as well.  I've completed three missions and the Plasma Cell has been available since the first one.  Are you playing on Steam?

Gaffi stick is also a recurring item to me too for melee hero to purchase.  At some point I thought it could be related to heroes (Vinto or Jyn have a blaster pistol hence maybe why the DH-17 and DL-44 were being pushed so much).  I tested with Fenn, Mak, Biv and Davith since none of them have a blaster pistol starting weapon but it did not change the fact that among the 8 items, DH-17, DL-44 and charged pistol were right there to purchase.  

I am playing on my android tablet.  I'm actually considering managing the armory by myself to allow more variety if it turns out it is not a bug.

Edited by IanSolo_FFG

Share this post


Link to post
Share on other sites
1 hour ago, Uninvited Guest said:

I know you said you have the latest update, but double-check the version number (latest is version 1.4) if you haven't already.  If it is the most recent version then you may want to send an email to software@fantasyflightgames.com.

Yes, 1.4.0 and still nothing. I'll mail them, thanks!

Share this post


Link to post
Share on other sites

Hi,

We resolved the first mission but not the first encounter. After saving, quitting and loading the same game the galaxy map remains empty.

Can you please resolve this?

Share this post


Link to post
Share on other sites
On 8/28/2018 at 3:54 PM, Lacustre said:

Yesterday I was playing and beating Mission 4 (mr Weiss guest star) and made a save as usual. Today I was prepared for the final mission, but I can’t find it, my galaxy map is empty!! The rest is ok: rewards, items... but nothing i n the galaxy.

I have the last update for iPad.

what can I do?? 

:(

I have the same issue but with the first mission!

Share this post


Link to post
Share on other sites
On ‎8‎/‎31‎/‎2018 at 1:23 AM, siezon said:

I have the same issue but with the first mission!

I also have the same issue.

Windows 10 - Steam

LoA version 1.4.0(244)

 

emptymap.jpg

Share this post


Link to post
Share on other sites

Lacustre, siezon & Treno,

If your campaign was started prior to installing the newest patch (1.4.0), in other words, if you started your campaigns during 1.3.0, your save data is still corrupted by the bug that occurred during 1.3.0 unfortunately.

New campaigns that you start shouldn't have this bug. If the bug persists, please send an email to software@fantasyflightgames.com, with your device specs, a description of the bug and ideally steps to reproduce the bug.

Share this post


Link to post
Share on other sites

On iOS (latest version) with app (latest version) we finished a mission a few days ago. Now, when we open the app, the galaxy is "empty" - tried tapping around the galaxy, but nothing happened. Tried resetting the last mission, and nothing changed - still empty galaxy. So... how do we proceed? Or must we start over from the beginning?!

Share this post


Link to post
Share on other sites

Running the app on a Macbook Air with El Capitan, the app just launches to a pink screen.

 

Also, running the app in Wine on Fedora 28 is just giving me a black screen after the Star Wars and FFG logos, but I guess this is unsupported anyway. A Linux version would be nice!

Edited by awesomeclaw

Share this post


Link to post
Share on other sites

I'm going to put my bug report in spoiler tags, since it deals with a mechanic from one of the missions in the Jabba campaign.

I just finished playing the mission where you sneak into the imperial base with the stealth mechanic.  After knocking out the initial three officers I was presented with the three elite stormtroopers while still in stealth mode.  We were discovered, reinforcements arrived and the firefight started.

At one point during the fight I had to switch to another application on my Android device; when I switched back the app was back at the title screen.  I loaded my save and things seemed fine, but when the elite stormtroopers activated their instructions were given assuming that I was still in stealth mode (move towards the blue, etc.).  It didn't have any other noticeable effect on my mission progress.

Share this post


Link to post
Share on other sites

I'm running the app on a PC from steam.

I ran into a bug on a playthrough of Jabbas realm. It was the first mission and I had progressed to the point where the second map had come into play (all the Heroes had slid down the slope a few turns before). I got to the end of the activations and the app did not progress to the next round. All the unit icons were indicating they had finished their activation. The last activation was an imperial unit. 

 

Share this post


Link to post
Share on other sites

In the Return to Hoth campaign on the first mission I encountered a glitch with an Imperial Officer.  I believe it was one of the initial deployments.  When it activated the Bonus was Squad Training (for each other figure in this group gain Pierce 1 - or something to that effect).   

Share this post


Link to post
Share on other sites

Similar problem to report as MFL above:

Campaign: Flight of the Freedom Fighter. Mission 2. My son and I had saved partway through the mission before the app update came through this week.

The Elite Nexu unit (which was already on the board when we last saved, before the update - in case it matters), was given the Bonus of "Squad Training", to gain Pierce 1 for each other figure in this group. Obviously makes no sense...

Too early to say if it only affects existing saves or newly spawned units. If I see any more I will report back.

Thanks.

Share this post


Link to post
Share on other sites

(Mid-mission saves through app version changes have the habit of messing up things. If needed, "reset mission" can be used to reset the mission and simulate it up to the point you got to the last time.)

 

Share this post


Link to post
Share on other sites

Thanks a1ber. I'll look for it in the menus next time. By 'simulate', do you mean that the app will restart the mission step through the key events (spawns and deaths) in the same order? Or do you mean for us to roughly repeat the events that occurred in the same order as far as we remember? If the latter, it's unlikely to repeat in the same way, as different units can spawn and randomised variables can be in effect, so that's not a great solution in my opinion.

Given the number of times I had to restart some of the missions due to glitches in the initial app release a year ago, I'm not sure I would have been brave enough to use a 'reset mission' button and start over. (Especially since it takes a while to guide and explain it to a 7-year-old as we go, but he's pretty determined and picks up rules well!)

For the record, an Imperial Officer also got the "Squad Training" bonus ability as we finished off Mission 2 earlier this evening. We'll see how Mission 3 goes in the near future.

 

Share this post


Link to post
Share on other sites

Interesting bug. Playing the hoth mission (unsure the name). But I did a save and quit right at the start (after it revealed the map, etc). There was a neutral mission token rule to "inspect shadows" (each neutral mission token is a shadow and there is some rule about interacting with it). However, it tells me to look at the neutral mission token rule to get the details, but their is no rule in the bottom center. On the latest version on an iPad.

Share this post


Link to post
Share on other sites
7 hours ago, totalnoob said:

Interesting bug. Playing the hoth mission (unsure the name). But I did a save and quit right at the start (after it revealed the map, etc). There was a neutral mission token rule to "inspect shadows" (each neutral mission token is a shadow and there is some rule about interacting with it). However, it tells me to look at the neutral mission token rule to get the details, but their is no rule in the bottom center. On the latest version on an iPad.

The workaround is to save&quit, Load Game, but before selecting the save slot, choose the cog icon and reset the mission.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...