Jump to content
Julia

SW: IA - APP - Bug Report

Recommended Posts

3 minutes ago, Majushi said:

I assume that will lose us our save files (for other campaigns etc )

For most platforms, I would assume so. Depending on the platform you may be able to make a snapshot of the app directory before deinstall/reinstall.

Finishing other campaigns in progress first would thus be prudent before trying this.

Share this post


Link to post
Share on other sites
4 hours ago, Majushi said:

I assume that will lose us our save files (for other campaigns etc )

 

4 hours ago, a1bert said:

For most platforms, I would assume so.

I had been playing on my desktop previously, but a couple weeks ago I installed it on my laptop and my older save files were loaded as well which indicates some kind of cloud/external network storage.  Again, this is using Windows so with Steam you’re safe.  It’s possible other platforms could do this as well.

Either way, taking a backup of you save directory prior to uninstalling would be a wise idea.

Edited by Uninvited Guest

Share this post


Link to post
Share on other sites

On iDevice, so no chance. Only had a tutorial mission starter before, so nothing lost.

running through the first mission again to see if it works this time. Trying to vaguely remember what I defeated first time around. Mostly it’s going to be the same, so end result should be mostly correct.

And having just run through the mission again, the same bug occurs.

Win mission, mission gives rewards, goes to galaxy screen and then It jumps out of the app and progress is lost.

 

Share this post


Link to post
Share on other sites

So, found a fix to my issue but not sure how repeatable it is.

when the mission is complete, and it loads the galaxy there is no thing there.

i just tapped in the general area where a planet might appear and suddenly Tattooine did!!

now if can shop and spend xp like normal...

Share this post


Link to post
Share on other sites

bdgolish, ookus, MAZZA, Majushi, Vazzucious and anyone who have a similar issue, please send an email to software@fantasyflightgames.com

The content of the email should contain:

  1. The specifications of your device
  2. The steps to reproduce the bug/crash
  3. Any other useful information that we could use to nail down this issue (For example, if you found a workaround or noticed something odd revolving around the issue)

Share this post


Link to post
Share on other sites

Ok! I found the fix
You have to open up the Save folder and edit your saves and logs

The basic LogA and LogB are for your campaign. Mine still had data from the existing campaign so I reset both to
[1|1|0]

The mission logs I believe are fine. I went ahead and copied everything from LogMissionA to LogMissionB.

Now for the fix. You will want to make a back up of your all your saves(i just copied the entire SaveGames folder).

To enable the encounter you will have to update the following item(the underlined item is the change)
{"Id":31,"Priority":0,"IsActive":true,"IsEligible":true}

To populate the market you will need to create a new campaign(and I would use the same characters) run through the first mission to complete it and use that campaign's save file to pull the market items ids.
Update the 2 items below
"StoreItemIds":[your item ids go are added here]
"StoreItemsCycling":[true,false]

for example mine looks like this - "StoreItemIds":[4,1,17,34,73,72]

Update the following items to fix skill selection:
{"Name":"Campaign/MaxSkillLevel","Value":1}

{"Name":"Campaign/HasPendingSkills","Value":true}

Share this post


Link to post
Share on other sites

Another person with the same problem reporting in, really frustrating and felt like the hours we put into learning and starting a campaign last night were for not. Sent an email. We even tried to do what Vazzucious recommended but going back through the first mission gave us the same blank campaign screen and no items or xp

Edited by varthanna

Share this post


Link to post
Share on other sites
22 hours ago, XMarleau said:

bdgolish, ookus, MAZZA, Majushi, Vazzucious and anyone who have a similar issue, please send an email to software@fantasyflightgames.com

The content of the email should contain:

  1. The specifications of your device
  2. The steps to reproduce the bug/crash
  3. Any other useful information that we could use to nail down this issue (For example, if you found a workaround or noticed something odd revolving around the issue)

Steam on SurfaceBook

When playing the first mission the game didn't start a new round after all the groups activated. Luckily I only had 1 survivor left and I was adjacent so I just clicked interact and the mission ended. Then I shopped and upgraded and did the encounter.

It seems to be okay after that hiccup. I'll continue on this weekend.

 

I'll send the e-mail as well. Thanks for responding FFG!

Share this post


Link to post
Share on other sites
10 hours ago, varthanna said:

Another person with the same problem reporting in, really frustrating and felt like the hours we put into learning and starting a campaign last night were for not. Sent an email. We even tried to do what Vazzucious recommended but going back through the first mission gave us the same blank campaign screen and no items or xp

When you repeat the first mission you don't need to do any activations. Just complete the objective to complete the mission(takes about 3 mins). You don't have to replicate the fame or anything since you will be using your previous save file and updating it. You only need to do this for the generated market items. If you need help I could generate them for you. You could also use my example to test it out.

"StoreItemIds":[4,1,17,34,73,72]

Share this post


Link to post
Share on other sites

 

On 8/8/2018 at 9:26 AM, ookus said:

Android Phone running updated 1.3 app. I fired up the new campaign to test it out and see the new features. During the first mission, I selected surrender to not spoil mission info and it ended the mission as expected. I was then brought to the mission selection screen with no options to continue to a new mission. When I opened the armory, I hear the card shuffle sounds but am not presented with any selections. I also wasn't able to select any upgrades for my heroes. I tried to recreate this but wasn't able too. But I have both saved games and confirmed the original save game still does not have any options to move forward. 

Hopefully this doesn't happen to someone several missions into a campaign. 

I'm part of the band too (Android tablet).  This happened to me after completing the first mission (save slot #2).  I had selected the Normal difficulty mode.  I restarted a new campaign in a different save slot (#5) on hard mode and I immediately selected surrender.   Then everything worked fine.  On the galaxy map, I could select Tatooine, the armory displayed weapons and upgrades for me to select and purchase and I was able to upgrade my heroes' XP.

I deleted all the campaign saved games and restarted one on normal difficulty mode in slot #5.  Then I replayed the mission and it worked fine after that. 

Share this post


Link to post
Share on other sites
1 hour ago, Uninvited Guest said:

@Vazzucious, in addition to what you noted I also found the "CurrentObjective" in the first or second line of my save file was set to M21_Objective_3, whereas the run through I did to get the items had M_Intermission_Objective.

Did you find anything like that when you were troubleshooting?

I did, but I left it. I don't think it mattered. Hopefully when you start the next mission it will overwrite with the correct value.

UPDATE
I went ahead and started on of the next mission. I am not seeing any issues with it.

Edited by Vazzucious

Share this post


Link to post
Share on other sites

I believe I have found a way to recreate the issue. It only seems to crash the save file if you save and exit during the mission and then load that save file. If you launch the mission and complete without exiting out the issue doesn't appear to be happening. What I don't know is if it hoses the rest of the missions or just that one.

Edited by Vazzucious

Share this post


Link to post
Share on other sites
On 8/9/2018 at 10:44 AM, XMarleau said:

bdgolish, ookus, MAZZA, Majushi, Vazzucious and anyone who have a similar issue, please send an email to software@fantasyflightgames.com 

The content of the email should contain:

  1. The specifications of your device
  2. The steps to reproduce the bug/crash
  3. Any other useful information that we could use to nail down this issue (For example, if you found a workaround or noticed something odd revolving around the issue)

Sent email with how to recreate and the workaround.

Share this post


Link to post
Share on other sites

I'm not sure if this is considered a bug, but the app kept telling me to bring out salacious crumb every round if he wasn't already out.  The problem is that he is a unique figure.  After I killed that little gremlin the first time, he should not be able to come back out during the mission.

Share this post


Link to post
Share on other sites

Android version of the game v 1.3.

1. Played the Flight of the Freedom Fighter on the version previous to 1.3

2. During the 4th mission I saved and updated the version to 1.3

3. Continued the mission and finished it.

Result:

* No new items in the armory

* No new class cards to select for my heroes

* The only mission selectable was the 4th mission (again)

After selecting and beating the 4th mission again there were still no new items in the armory, and no new class cards - Also there was no mission or encouter or nothing to select on the campaign map.

Share this post


Link to post
Share on other sites

Is  anyone having problems w the new campaign on a mac? Everything I'm seeing in the thread seems to be related to mobile os or windows. About to start a campaign tmw and just want to know if I should expect any problems.

Share this post


Link to post
Share on other sites

Regarding the bug of not seeing missions, upgrades and armory. I did notice the last time through that the campaign log showed data from a Flight of the Freedom Fighter mission. I tried to recreate this but I didn't see this the next time around. I'm wondering if anyone else is seeing this as well?

Just reading the below info from Vazzucious this morning. I do have this application installed on 2 windows devices that are both logged into Steam. This makes me think that the game being saved between these two devices could be part of the issue. I did do an uninstall of the application on one of my devices, reinstalled and tried to load up the mission (from steam) and still did not see the new mission, upgrades and armory options. 

On 8/9/2018 at 11:24 AM, Vazzucious said:

Ok! I found the fix
You have to open up the Save folder and edit your saves and logs

The basic LogA and LogB are for your campaign. Mine still had data from the existing campaign so I reset both to
[1|1|0]

The mission logs I believe are fine. I went ahead and copied everything from LogMissionA to LogMissionB.

Now for the fix. You will want to make a back up of your all your saves(i just copied the entire SaveGames folder).

To enable the encounter you will have to update the following item(the underlined item is the change)
{"Id":31,"Priority":0,"IsActive":true,"IsEligible":true}

To populate the market you will need to create a new campaign(and I would use the same characters) run through the first mission to complete it and use that campaign's save file to pull the market items ids.
Update the 2 items below
"StoreItemIds":[your item ids go are added here]
"StoreItemsCycling":[true,false]

for example mine looks like this - "StoreItemIds":[4,1,17,34,73,72]

Update the following items to fix skill selection:
{"Name":"Campaign/MaxSkillLevel","Value":1}

{"Name":"Campaign/HasPendingSkills","Value":true}

 

I have not reached out to FFG via software@fantasyflightgames.com but I'll do that today. Frustrating to see people are seeing this past the first mission. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...