Jump to content
Julia

SW: IA - APP - Bug Report

Recommended Posts

Although not a bug, perhaps a 'design limitation' which could be easily rectified:

As mentioned in this topic, if you transfer a save game to another device and put the files into a folder corresponding to a different 'slot' number, when you load and later save this game, it will write to the original slot number which it had on the original device. It will ignore the slot number that you put it in by folder number.

This can result in data being overwritten and lost in that 'old' slot number. The 'new' slot number you transferred the save data into remains unchanged from its original state. Further details described in the linked thread above.

Perhaps the transfer of save game files is not an 'officially' supported process, but clearly quite a few people have had a need to do this operation to transfer campaign progress to a bigger screen, in the absence of any cloud-based synchronisation features.

My experience was on the latest Android version. I haven't tried to repeat it, I must admit. (After I lost my progress and was trying (fruitlessly) to re-run a few rounds of mission 2 countless times in the hope of 'recovering' back to the point I was at, I lost the will to live! ;) )

I would love to see a cloud-sync added in the future, perhaps linked to our Asmodee/FFG accounts. The save files are only a few bytes after all.

Share this post


Link to post
Share on other sites

After losing our Mission 2 progress to the issue of "moving save files to another device but using a different folder/slot number" (two posts above), tonight we lost our progress in Mission 2 again, because the app would not advance beyond Round 6.

I have sent a lengthy e-mail to FFG's software support e-mail address to describe the events with screenshots, and sent the save files too, so I hope the reason can be found and fixed.

In summary, after all units activated and the round 'clean up' occurred, no new round started. Meaning: No round title appeared at the top of screen, and all unit portraits remained in their red/blue-shaded 'already-activated' state. Saving and loading the game only triggers a new unit to spawn. After activating that unit manually and clicking 'Finish' on their activation, nothing else happens. Saving and loading again triggers another new unit to spawn, in addition to the last one. And so on...

I'm only posting here to raise awareness in case anybody else encounters a similar problem.

Time for us to start a whole new campaign from scratch, in case of some error in our save files, and try Mission 2 for the third time :blink:

Share this post


Link to post
Share on other sites
Posted (edited)

I am incredibly impressed with this app - really well done. Not really a bug , but just somethings that would help

- An undo action is sorely needed. I accidentally defeated one of our freed tokens which ended the mission when I intended to defeat an officer. That was pretty frustrating as it was in round 8 :(

 

Also on the same mission, the original text for the freed crew members said that they can be protected from attack if a hero is within one space. However, later apparently the Empire can target then directly meaning that this rule doesnt  apply anymore. When tapping on the token, the pop up text should be modified to NOT include the rebel protecting ability anymore. This differing of instructions confused us , leading to playing it incorrectly.

Also, any way to improve the random figure spawns to be a little more thematic would be great. 

Overall this is a great product!!!!

Edited by totalnoob

Share this post


Link to post
Share on other sites
2 hours ago, totalnoob said:

- An undo action is sorely needed. I accidentally defeated one of our freed tokens which ended the mission when I intended to defeat an officer. That was pretty frustrating as it was in round 8 :(

I second that. An undo button would be most welcome. I also defeated a mission token before my wife reminded me I could have taken the hit myself as I was standing adjacent. No way back after that, and it was the last token so it totally changed the mission outcome. Oops... :wacko:

Another 'wishlist' item which I saw mentioned before: It would be great if the 'Activation' tab at the bottom was more obvious. A couple of times I feared the app was stuck, but it turned out I'd just minimised the activation window (view map option) to view a mission token's rules, then forgot I'd done it by the time we resolved the turn.

I do hvae one minor bug to report:

On the Android version, whenever an interactive object (door, crate) in the 3D map view is under the UI portrait for a hero or rebel (top left or bottom left), tapping on the hero/rebel portrait actually selects the door/crate underneath. The pop-up window appears for that door/crate instead of the 'defeat/end activation' option for the hero/rebel unit. It gets very frustrating some times and we have to constantly shuffle the map view around to avoid it. I can't replicate it on the Steam version on my PC, only using touchscreen on Android. I've no idea if it device specific.

Share this post


Link to post
Share on other sites

Just thought I’d report that my phone ran the most recent app update at midnight a couple nights ago. We were (intensely) playing the fourth mission when my phone updated. It saved at the end of the previous round but we lost all the random spawns that we were playing against. I really like the app, but this sort of thing is a bummer.

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, a1bert said:

The phone updating apps without asking is not the app's fault though.

 

Fair enough. You can take it as a warning if you prefer: You may want to disable automatic updates before playing the app...especially if you think your game will be going till midnight (or whenever your phone typically updates) otherwise you might run into problems.

Also (MISSION 4 SPOILER- includes plot spoiler).

 

We also had an issue where we opened a door and Burin appeared. The app immediately allowed Burin to activate even though we were in the beggining of Mak's activation when the door was opened. I'm not sure if this is a bug or if this was intended but it felt odd. 

Edited by VadersMarchKazoo

Share this post


Link to post
Share on other sites

Surface Pro 3 - i5/8mb/256gb

Touch controls don't appear to be working on my Surface Pro 3 - have tried it with "Tablet mode" both on and off, with keyboard attached / detached and mouse connected / disconnected (and the variety of combinations therein) 

Share this post


Link to post
Share on other sites

I don't have a screenshot, but while playing through the first mission (Windows 10 PC), all the text seemed to get replaced with ID tags instead.

So instead of saying something like "Press the blue button to open the door", or whatever, it would say "TEXT_BLUE_DOOR_MISSION_1". (That's not a specific accurate example, but the kind of thing it was doing). Restarting fixed it, but we had to skip through page after page of text like that before getting to a point where we could actually leave the game. No idea what important information we might have missed in the meantime.

Also, yeah - as someone else said, "add all expansions" would be incredibly useful. I installed the app on my desktop and had to go through every expansion, one at a time, to select it, add it, confirm, repeat. Then I installed it on my laptop as well, and as it didn't remember the expansions associated with my Steam account (which seems like a bug frankly), I had to do it all over again! Exactly the same for the Descent app too; if only they'd listen to feedback...

Share this post


Link to post
Share on other sites
On 3/27/2018 at 7:09 AM, Bitterman said:

Then I installed it on my laptop as well, and as it didn't remember the expansions associated with my Steam account (which seems like a bug frankly), I had to do it all over again! Exactly the same for the Descent app too; if only they'd listen to feedback...

The all the data is stored locally from what I've seen, so that sort of information wouldn't transfer between your computers/devices.  This wouldn't be a bug, but it has me wondering if they have a means of submitting Enhancement Requests.

Share this post


Link to post
Share on other sites

We played through on Hard difficultly yesterday and after we'd won an Ally Encounter for the Wookiee Warriors, we were only presented with the option of picking the Rebel Saboteurs for the following mission, despite not having done their encounter. Sadly at the time we didn't screenshot it and we simply played on using the Saboteurs. We're running the app on a Macbook with OSX High Sierra (I think that's the OS name!)  

Share this post


Link to post
Share on other sites

Steam version 1.2.0

During enemy activation if you click the "i" button on a defeated hero (one that has been defeated twice and can only move) then the activation window disappears with no way to get it back. Defeating another hero brings it back.

This was during the "retrieve the star chart from the imperial transport" mission.

Share this post


Link to post
Share on other sites

This isn't actually a bug, but an enhancement request. The current app only has one graphics quality option "Desktop". I have cheap windows tablet that performs much better when playing Mansions of Madness using the "Mobile" graphic setting than the "Desktop". I was just hoping the "mobile" graphic quality would be an option in future updates.

Share this post


Link to post
Share on other sites

Not bugs per se but feature enhancements:

 

1. please add "Habitat" checking - no wompas in the desert, jabba in an imperial base, jawas in a jungle etc etc

2. Pleae, please , please add an undo button. I've managed to "kill off" the wrong enemy group on the app a couple of times now (once even an ATST instead of an EWeb), it would be nice to be able to undo the last action taken

 

Otherwise I am absolutely loving this app and the new dynamic it's made to the game.

Share this post


Link to post
Share on other sites
On 3/27/2018 at 5:09 AM, Bitterman said:

I don't have a screenshot, but while playing through the first mission (Windows 10 PC), all the text seemed to get replaced with ID tags instead.

So instead of saying something like "Press the blue button to open the door", or whatever, it would say "TEXT_BLUE_DOOR_MISSION_1". (That's not a specific accurate example, but the kind of thing it was doing). Restarting fixed it, but we had to skip through page after page of text like that before getting to a point where we could actually leave the game. No idea what important information we might have missed in the meantime.

I had the same thing on the mission (#3?) where you have to rescue the captured rebel mission tokens. I couldn't remember how much health the tokens had or what defence die they rolled, so I clicked on the token in the app. Instead of that info I got "M_02_CREW_RESCUED_DEADLY" which was not terribly helpful.

 

Share this post


Link to post
Share on other sites

Version 1.2.1, second mission (I think). The one where you escort the 4 captives to their ship. End of round 2 got in the ship, 2 moved, everything was activated. But a new round didn't start. Save-quit and restart and a new imperial spawns, but still nothing activates. This was the round after our ally group was defeated.  No way to continue, except to declare the remaining two captives as defeated, then it triggered end game.

Share this post


Link to post
Share on other sites

I played my 8th playthrough, and first with new Allies code, I got C-3PO in my first Ally mission. He 'died' at the hands of Palpatine in the mission. I didn't get another Ally mission until the last chance before the final mission. I got Chewbacca in that one. Has anyone else has this experience? I remember in previous playthroughs getting a lot more ally opportunities. 

Share this post


Link to post
Share on other sites
On 5/20/2018 at 1:55 PM, The Cocky Rooster said:

I played my 8th playthrough, and first with new Allies code, I got C-3PO in my first Ally mission. He 'died' at the hands of Palpatine in the mission. I didn't get another Ally mission until the last chance before the final mission. I got Chewbacca in that one. Has anyone else has this experience? I remember in previous playthroughs getting a lot more ally opportunities. 

My first playthrough only gave me one ally encounter, and the second gave me two.

Share this post


Link to post
Share on other sites

Using an iPad series 6, the program seems to not only turn the application off, but revert to the iPad lock screen, I think the timeout on the iPad (which is set to 15mins) creates a weird trigger in the program - I have to unlock the iPad and restart the application and revert to the last  saved point (previous end of turn).

I think the single taps that I make on the icons aren't registering on the iPad as activity.

I have turned off the timeout setting, but not tested the app yet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×