Jump to content
werdnaegni

Tabletop Admiral overhaul almost complete. Feedback pleeeeease

Recommended Posts

So...

The 'Choose Faction' page looks identical to the one you get when you're not logged in (besides checking the name in the upper right corner, I know).  This is the second time I've built a squad and had no way to easily save it to my account because all paths to logging in after the fact, clear the page...

Would it be possible to add a bold red header above 'Choose Faction' (or something obvious and pretty) that warns people the list won't be save-able unless they are logged in?  Perhaps an intermediate, auto-timeout page with the warning (click here to continue now) sort of thing...

Cause (I know it's my own fault but) I'll never remember exactly what I did.  :(

Share this post


Link to post
Share on other sites

A temp fix for that is to copy the link at the very bottom, log in, and paste it in your browser adress bar. And yes, I talk from the same experience :P

Share this post


Link to post
Share on other sites
Posted (edited)

FYI

I made some code for Startactics IA Android App and sent that to the owner. It should allow the app to export army lists from the app to TTAdmiral and import from the website into the app using the URL format.

Hope it will get accepted, I think it may be a nice feature.

I'll keep you posted.

Edited by Golan Trevize

Share this post


Link to post
Share on other sites

I remember somebody in the forum suggested Vasal compatibility as a possible feature.

If i remembered well it is built in now.

I found the java export option (.json format) but cant import it to Vasal.

Am I missing something or my memory fails me?

Thanks for the help in advance.

Share this post


Link to post
Share on other sites
1 hour ago, Ace_of_Spades said:

I remember somebody in the forum suggested Vasal compatibility as a possible feature.

If i remembered well it is built in now.

I found the java export option (.json format) but cant import it to Vasal.

Am I missing something or my memory fails me?

Thanks for the help in advance.

I don't know but the idea of importing or exporting files in my opinion is at least 25 years old in today's computer science. I don't see why copy and pasting an URL or perhaps taking a picture of a QR code shouldn't allow you to save a list in your mobile app. I imagine competitions where people shares their lists with QR codes. Every time I see paper and pen I feel like I should go back to the cavern and survive by farming or hunting!

Share this post


Link to post
Share on other sites
Posted (edited)

@werdnaegni

Couple things I've seen lately:

Using Chrome, and I did clear my cache.

When logged in and i chose the Imperial symbol, the filtering only shows the card Motivation, so i can only used the "unfiltered" functionality. I'm also not able to add Command Cards. When I'm logged out, its not an issue. 

When not logged in, there isn't a Print or JSON option. 

Edited by wannabepudge

Share this post


Link to post
Share on other sites
On 3/12/2018 at 12:31 PM, GilDK said:

I cant log in, have had that problem for a few weeks now

 

Sorry if I'm just now seeing this. I want to say we sorted this out through email though iirc? Let me know.

On 4/3/2018 at 1:38 AM, Ace_of_Spades said:

I remember somebody in the forum suggested Vasal compatibility as a possible feature.

If i remembered well it is built in now.

I found the java export option (.json format) but cant import it to Vasal.

Am I missing something or my memory fails me?

Thanks for the help in advance.

So the JSON (javascript object notation, note; not JAVA), i believe was supposed to go through someone else's interchange format, and then into Vassal.

I'd have to dig and find out who I was in contact with for that, but yeah you can't dump it straight into Vassal. I tried to work with the Vassal code and figure something out but to me the code is incomprehensible.

On 4/5/2018 at 12:22 PM, wannabepudge said:

@werdnaegni

Couple things I've seen lately:

Using Chrome, and I did clear my cache.

When logged in and i chose the Imperial symbol, the filtering only shows the card Motivation, so i can only used the "unfiltered" functionality. I'm also not able to add Command Cards. When I'm logged out, its not an issue. 

When not logged in, there isn't a Print or JSON option. 

Well that's weird. Is your collection page normal? Could you give me your account name so I can see if some weird error happened with your collection? 

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, werdnaegni said:

Well that's weird. Is your collection page normal? Could you give me your account name so I can see if some weird error happened with your collection? 

You're looking at it haha.....wannabepudge.

yea, i believe the collection page all looks normal. The builder is just messing with me when logged in.

Edited by wannabepudge

Share this post


Link to post
Share on other sites
14 minutes ago, wannabepudge said:

You're looking at it haha.....wannabepudge.

yea, i believe the collection page all looks normal. The builder is just messing with me when logged in.

I'm looking at your collection now, and it says you own 3 packs: Han Solo, Luke Skywalker, and Chewbacca. No core or anything.

But your collection page says you own more than that?

Share this post


Link to post
Share on other sites
1 minute ago, werdnaegni said:

I'm looking at your collection now, and it says you own 3 packs: Han Solo, Luke Skywalker, and Chewbacca. No core or anything.

But your collection page says you own more than that?

Well that makes sense. I have no recollection of changing that as it once upon a time had everything i owned haha. I'll fix that and i'll assume that fixes my experience. thanks!

Share this post


Link to post
Share on other sites
On 16/4/2018 at 7:43 PM, werdnaegni said:

Sorry if I'm just now seeing this. I want to say we sorted this out through email though iirc? Let me know.

So the JSON (javascript object notation, note; not JAVA), i believe was supposed to go through someone else's interchange format, and then into Vassal.

I'd have to dig and find out who I was in contact with for that, but yeah you can't dump it straight into Vassal. I tried to work with the Vassal code and figure something out but to me the code is incomprehensible.

Well that's weird. Is your collection page normal? Could you give me your account name so I can see if some weird error happened with your collection? 

Yes we are sorted, thanks for all the help and the great site.

Share this post


Link to post
Share on other sites
On 5/17/2018 at 3:19 PM, HeliosLancer said:

It looks like the Image for  "Take it Down", Gideon's command card isn't loading.

Whoops. That should be fixed now. Sorry I'm just now seeing this. Feel free to tag me next time.

Share this post


Link to post
Share on other sites

Hi, I just noticed that the collection fields on the IA collection builder are squashed so you can’t see the numbers properly, and everything has a value of 5. There is also a “none” entry.

There was a similar problem for legion awhile back but that seems to be fixed. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×