Jump to content
kraisto

Road to Legend Bug Report

Recommended Posts

Just wanted to report a bug in Seeds of Corruption:

We had no more main scenario quests pop up:

It seems to trigger when you get the ynfernal rune in the main quest but then lose that scenario, we tried it twice and both times we had no main quest show up afterwards anymore. So we got the rune, but then couldn't make it to the escape room next door since we got overrun by enemies.

We then tried to recreate our save state to continue playing and it happened again. No main scenario quests.

For the third try we just clicked that we managed to escape and now the main quests pop up. So it seems to be a quite special situation to trigger this bug. We play the app on a PC via Steam.

Share this post


Link to post
Share on other sites

Is is just me or the Crypt Dragon activations always suck? They are always super stationary and it sometimes work (when they defend an objective) but sometimes they are useless. Sucks cause I love how this unit looks.

Share this post


Link to post
Share on other sites

version 1.3.1

started goblin tutorial - defeated the zombies, the barghests appeared, saved my progress, when restarted, the zombies were still the current monster, even through the journal records that I had defeated them.

This is why I don't have faith or conviction in companion apps, I'm afraid of spending hours in a campaign, and all it takes is something like this to ruin and make void the whole game.

 

Share this post


Link to post
Share on other sites
Quote

 

Just wanted to report a bug in Seeds of Corruption:

We had no more main scenario quests pop up:

It seems to trigger when you get the ynfernal rune in the main quest but then lose that scenario, we tried it twice and both times we had no main quest show up afterwards anymore. So we got the rune, but then couldn't make it to the escape room next door since we got overrun by enemies.

We then tried to recreate our save state to continue playing and it happened again. No main scenario quests.

For the third try we just clicked that we managed to escape and now the main quests pop up. So it seems to be a quite special situation to trigger this bug. We play the app on a PC via Steam.

 

My friend and I have just experienced the exact same bug on ipad.

Share this post


Link to post
Share on other sites
On 1/17/2017 at 5:03 PM, ChanceRiley said:

Also, Bug in Smash and Grab, when making a check to see how much health the wraith has left, instead of the second option, there is the date: 1/6/2016

I saw the same bug, although I think for me, it said 1/4/2016

I'm thinking it was supposed to be "1-4", and got translated to a date.  (The other options were 0 and 5+, so 1-4 as a range seems to fit.  We were playing two heroes, so maybe with more heroes the range is 1-6?)

I don't have my tablet handy, but I'm using the most recent version of this app (1.3.1 or 1.3.3?  I can't recall right off).

Edited by sigmazero13

Share this post


Link to post
Share on other sites

Just got back from a gaming session playing through the Seeds of Corruption campaign. Did the Intro Quest, 3 Side Quests, but once we got to the next real Campaign (non side quest) it wanted us to place tile 72. Not wanting to spoil the layout and see if it actually was required we called it a night. Doing some searching over at BGG I found the data from the app that appears to correlate with this bug. As we did not play through I am unsure if that tile is required or not. Tile 72 is not included in SoN.

//In a Manor of Speaking
SOC_Q_IAMOS_TILES,"Set aside tiles 3, 7, 23, 26, 51, 52, 53, 54, 55, 56, 57, 59, 60, 62, 72."
SOC_Q_IAMOS_TILES_ALT,"Set aside tiles 23, 26, 51, 52, 53, 55, 59, 60, 62, 71, 72, 73, 74, 76, and 77."

 

Further down in the thread on BGG it is mentioned that 72 doesn't seem to be placed. So it looks like just removing that number from the first string would be sufficient.

Edited by Booze2Looze
Additional Relevant Information

Share this post


Link to post
Share on other sites

Potential bug in SoC side quest Time Trials.

This quest has you attempting to complete 3 trials.  For each trial you successfully complete, your goal of drinking from a container (objective token) is not impeded ... that is to say that no monsters spawn within that area.

We completed the first time trial which involved destroying half built statues.

We completed the second time trial which involved escorting a group of villagers (represented by a single villager token) to a rescue point, and defeating a named monster called Inqis (or something similar).

We failed the final trial of killing a named monster.

So, what was supposed to happen was that areas 1 and 2 should be devoid of all monsters making it easy to get to the objective tokens from which we needed to drink, while area 3 would be repopulated with new monsters.

Unfortunately for us, while area 2 was empty, and area 3 was appropriately filled with new monsters, area 1 was also filled with new monsters as if the system did not register the fact that we had completed the trial.

Edited by any2cards

Share this post


Link to post
Share on other sites

Playing Delve and I have a quest that starts out on the following map:

pic3623027_t.jpg

There are blue objective tokens where the red Xs are and the portal is closed to begin with. The blue objective tokens can be defeated with damage attacks.

Two elementals are on the map that can not be damaged and do not block movement or LOS.

My heroes ran to the blue tokens and defeated them. As soon as the second token was defeated, the app told us that the elementals can now be treated as normal. From my event log:
pic3623030_t.jpg

I understood the "elementals are now treated as normal" part to mean that they now 1) block LOS and movement, 2) can take damage, and thus, 3) can be defeated.

I attacked and defeated the elementals. When I clicked on the elemental icon in the App and chose "Defeat Group", the app displayed a the following message:

pic3623039_t.jpg

I did a double-take while saying something like "Hubba--wha?"

So, only once you waste precious time to kill both elementals and then try to tell the app that they are defeated are you told they can't be defeated. At that point, you have already taken them off of the map and possibly taken several turns since the first one was removed from the map.  Everything is all screwed up and cannot be fixed. You literally have to surrender the whole campaign and start over from scratch.

So, one of the following must be true:

1) They should be able to be defeated after destroying the crystals. (Bug with the "Defeat group" logic.)

2) They can never be defeated. (Bug with the instructions.)

3) The instructions and Defeat Group logic are working as intended and this is the single biggest troll event in board gaming history.

I am guessing #1.

Thoughts?

Edited by grahamers
Typo

Share this post


Link to post
Share on other sites
2 minutes ago, streamdragon said:

Possible bug in Shadows of Nerekhall.  After escaping the initial dungeon, when talking to Kaplan I cannot choose the "What do the voices say? [Hexer]" option, even though I have a Hexer in my group.

Just curious- do you have a "hexer", or a "steelcaster hexer".

Share this post


Link to post
Share on other sites

I have purchased the Delve expansion, and while it works fine under my Android Phone, it will not let me select it under my android tablet with the same account.  Nor will it even let me purchase it again.  I've tried re-installing it, with no luck.  Any advise?

Share this post


Link to post
Share on other sites

I'd like to report, that in new version of Delve in Czech Languange there are some font issues - in almost every sentence the font is broken, where it replaces some letters with capital letters inside words from some generic font. This usually happens, when the font you use does not support Czech language. Please change it

Also, there could be possibility to check at expansions, if I want the names to be in english or translated, because in Czech, there is only Base game and first big expansion localized, so we buy all other components with english texts and when app is well done and translated everything we now need to do back translation of abilities and monster names back to english to get the right one.

Edited by Zaily

Share this post


Link to post
Share on other sites

Since the update today this is how the game looks on my Nexus 7 tablet running Android 4.4.4.

In Google Play it says the app is still supported for Android 4.0.3 and up.

As you can see the app is unplayable like this (there are monsters on the right that can't be seen).

 

Also I've had issues with the "Load Game" screen not always loading. After the update I tried uninstalling and reinstalling as I had all 5 save slots filled and the app would hang after selecting "Load Game". Reinstalling has erased all my saved progress

screenshot.jpg

Edited by ZiggyOz

Share this post


Link to post
Share on other sites

Reported some bugs months ago (marrow priest surge info and serena lieutenant activation)and none of them have been fixed in the latest patch. Its not really hard fix some lines of text in the app  :angry:

Share this post


Link to post
Share on other sites

Not sure if this is a "bug" per-se, and I can't remember which quest it was, but there was a quest that had the Dispossessed as an enemy, and all their cards activates require them to either get the hero token, or use it.  IE, none of the actions ever let them move on their own.  This kind of made that quest really easy since all we had to do is stay out of their LOS and they would just stay put forever.

Share this post


Link to post
Share on other sites

Bug in the side quest: Tooth and Blade

Deep Elves are treated as hero figures and are instructed to attack monsters in their first activation. However, in their second activation the AI instructs them to attack heroes! 
There was a similar problem in the Seeds of Corruption quest "The Archive", that had been resolved recently. 

Share this post


Link to post
Share on other sites

Trials of frostgate came with a serious bug. The load game button gives a black screen on. App can still be closed and reopened only if you remove it from the current apps list. 

Version v1.4.0(360)

Android v 5.0.2

Asus Zenpad P022

There are quite a few others mentioning it in play store feedback.

 

 

 

Edited by Ceahorse

Share this post


Link to post
Share on other sites

v1.4.0(360) running on Android 4.4.2

After I create a save game, any time that the app tries to access the save game screen again, either to load the current save or create a new game, it just displays a black screen.

I have to delete all data for the app and start it again to begin a new game.

Obviously, this prevents me from saving games partway through.

Share this post


Link to post
Share on other sites
1 hour ago, Ceahorse said:

I'd say this is an April Fool's Day Prank

One might assume this, but in reality it's just a wrongly formated field in an excel sheet, that autoconverts the entry 1-4 to a date.

Edited by DerDelphi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...