Jump to content
kraisto

Road to Legend Bug Report

Recommended Posts

We played the Enemy of My Enemy quest and due to never ending stream of kobolds took so long that we triggered the Final Peril (?) stating that we would lose the quest in two rounds.  Two rounds later the quest kept going.  We simulated two more rounds just to make sure we didn't mess something up and ultimately forfeited (as it was the most tedious quest we'd ever played - stupid kobolds!).  We would have preferred a legitimate defeat screen.

 

Edit - this was the Kindle Fire version.

Edited by Keithh

Share this post


Link to post
Share on other sites

There seems to be a pretty big bug in I believe it was the Temple of the Elemental Dragon side quest.

You have to match certain items with certain ethereal warriors, yet the app doesn't process the choices correctly.

I choose to match say "water" with a certain warrior, and the next time "fire" is greyed out in the choice list and "water" is still available.

Just like to add that we also got this bug yesterday.

Ethereal choices were totally screwed up.

Played on ipad with latest ios as for 20th june 2016

Road to legend version 1.1.1.

Share this post


Link to post
Share on other sites

Hi. I've stpped playing since this problem showed up. The application crashed as soon as I tried to load my saved game. The screen goes black, then I'm return to the ipad Air's home screen. After reading this forum, I had the idea to increas the number of my owned expansions and try to load again. It worked, but when I tried to remove the expansions, loading the saved game said that these expansions where required now! At this point, I can only enter my saved game if I add these epansions. Because of this, I feel I won't be able to continue because it will ask me for tiles and monsters I don't realy own. I hope you can patch it si I don't have to restart another campaign or buy all these expansions ;) . The app is great. Hope this helps you resolve this important issue. Saved games are precious to players, as you well know, I'm sure.

Share this post


Link to post
Share on other sites

Outch, you messed up the save filled structure. A sugestion, its better add a structure that suporte multiple save files for a campaign. At last you can load a previous file save from a previous quest for example.

Share this post


Link to post
Share on other sites

Hey guys!

Windows 8.1 steam version with touchscreen:

Starting a campaign requires entering party name. Clicking on text field doesn't bring up software keyboard. Physical one is required to play. Leaving party name blank doesn't allow to continue. Either needs a fix to bring sw keyboard, or to have a default party name pre-set (so that you don't have to enter something if you don't want to).

-zxql

Share this post


Link to post
Share on other sites

My game save is fixed with the last update. I just want to say i am really glad to see their commitment to this app. I will 100% support them and buy future campain.

Share this post


Link to post
Share on other sites

My game save is fixed with the last update. I just want to say i am really glad to see their commitment to this app. I will 100% support them and buy future campain.

 

Updated yesterday, full changes in the first post in this topic ;)

 

Now I waiting for a fix in the monsters activations :(

Edited by kraisto

Share this post


Link to post
Share on other sites

I do not have the app in front of me at the moment but I believe the activation steps for a shade may have an issue.  The effect, if memory serves, states that if a hero fails a perception (eyeball stat), then they become terrified.  During the activation instructions it only says to use flicker, which tests perception, on enemies that are terrified.

Share this post


Link to post
Share on other sites

The mission to assault the castle, can't remember the name, at the start where all the Board Pieces are listed, it missed one out. 

Tile 55 was not in the initial list, but was required as the mission progressed.

Share this post


Link to post
Share on other sites

possibly not a bug, but stiil: town inventory refreshes after returning to main menu and loading quest. i had expected that it will be saved with other data.

it makes limited shop inventory obsolete, because players can return to main menu and load campain until they have bought every item, they are intrested in.

Share this post


Link to post
Share on other sites

This may have already been caught & fixed, as it was a few patches ago now. 

The pic below shows a typo in what I think was a travel event?

 

TypoRTL.jpg

 

Nope - it's a real word.

Share this post


Link to post
Share on other sites

Really? So it is.

I actually thought it was two incorrect words, never occurred to me it was one correct word!

Ignore that then, nothing to see here, move along.

 

Haha I see now - yeah the spacing is really bad ... it does look like two words!

 

In another universe I'm sure it is meant to say "A knight all in bronze armor stands with Wart, the bridge" ... 'cause, you know, every knight has to name his bridge!  :lol:

Share this post


Link to post
Share on other sites

I can just exit to the title screen and re-load the Campaign to update and refresh the items in Tamalir's shop.  This costs nothing, so the "Wait 1 Week" button seems kinda superfluous.  This also re-generates side quests in locations I've already completed (although so far, they are different side quests than the ones I've done).  Working as intended?

 

I'm playing on an old-school Ipad 2.

 

- Jee

Edited by Inspector Jee

Share this post


Link to post
Share on other sites

Ran into the following bug on Android:

 

After shopping, our party had 7 gold left.

 

We travelled to a sidequest and a travel event hit us. We had the choice between having 16 gold stolen from us or doing something dangerous.

As we only had 7 gold, we chose to loose the money.

 

Now we have -9 gold.

 

Thievery shouldn't be able to instantly put you into debt. :D

Share this post


Link to post
Share on other sites

Ran into the following bug on Android:

After shopping, our party had 7 gold left.

We travelled to a sidequest and a travel event hit us. We had the choice between having 16 gold stolen from us or doing something dangerous.

As we only had 7 gold, we chose to loose the money.

Now we have -9 gold.

Thievery shouldn't be able to instantly put you into debt. :D

You are in debt with the Thieves Guild ;) . For the gameplay standpoint, its not a bug, but a penalty.

Edited by kraisto

Share this post


Link to post
Share on other sites

Please forgive me for not reading all posts first...

Reporting bug with shop inventory.

My understanding is that the ship inventory should not change unless a week of game time has passed.

If, however, the game is exited and the campaign reloaded and the party checks the shop inventory, the shop inventory will have refreshed. This allows for players to repeatedly check the shop inventyory without having to expend game time to refresh the inventory.

Share this post


Link to post
Share on other sites

Bug report.

Yesterday, my family started a second campaign. Completed the training quest. Went to town. Bought gear.

Did not exit the App.

Today, when I clicked on the app, it launched like it was not already running.

Loved the campaign.

The map does not show the side quests or the next major quest.

The only Hong we see is Tamalir. We can go to the city and buy and sell hear. We can leave the city.

Nothing else but Tamalir is on the map.

None of the bottons work - cannot get to the main menu, the training menu, the inventory, and the journal.

:(

Stuck in limbo.

Share this post


Link to post
Share on other sites

Bug report.

Yesterday, my family started a second campaign. Completed the training quest. Went to town. Bought gear.

Did not exit the App.

Today, when I clicked on the app, it launched like it was not already running.

Loved the campaign.

The map does not show the side quests or the next major quest.

The only Hong we see is Tamalir. We can go to the city and buy and sell hear. We can leave the city.

Nothing else but Tamalir is on the map.

None of the bottons work - cannot get to the main menu, the training menu, the inventory, and the journal.

 

What platform are you running the App on? (iOS, Android, Windows, Mac)

 

What version of the App are you running? (current version 1.1.3)

 

If I recall correctly, one of the updates addressed the very issue you are describing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...