Jump to content
Sign in to follow this  
irontrap

GR-75 Broken Engine

Recommended Posts

So my rebel transport arrived today, but one of the the engines is broken off and floating around in the package.

Is it easy to fix? Or should I contact customer support?

14330208554_2f816a4a70_c.jpg

 

14327593071_c72cf3b348_c.jpg

Edited by irontrap

Share this post


Link to post
Share on other sites

Like everyone already said, that *should* be an easy fix.

 

Take a few more pictures, (that make it extremely obvious what's wrong) then see if you can glue it. If you can't, or something else is majorly wrong with it, shoot customer support an email. They're awesome. :D

Share this post


Link to post
Share on other sites

Lots of people have had this happen... Many have reported it snaps right back in place.  Others like myself used a dop of super clue and had survived a 5 foot drop (placed loose on my game mat) in the top bin of a plano 1374.

Share this post


Link to post
Share on other sites

The command pod on one of mine was loose, but a little bit of glue fixed that right up. (The same has been true for a Bomber wing and something else silly.)

 

What's bothering my OCD, on the other hand, is my second transport is straight up MISSING the forward-most container on the underside. It's not loose, it's just AWOL.

 

It really shouldn't matter, but... it bugs me.  :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...