Jump to content



Photo

Design cards, Strange Eons 3 plug-in


  • Please log in to reply
40 replies to this topic

#1 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 17 June 2013 - 08:40 PM

A plugin that allows fans to design their own cards is available on the Strange Eons 3 catalog.

 

Instalation and usage guide: http://susurrosdelbo...range-eons.html

 

Current version is beta 6.

 

Strange Eons: http://cgjennings.ca/eons/index.html


Edited by karagh, 19 September 2014 - 09:12 AM.


#2 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 17 June 2013 - 08:42 PM

Beta 1 released.

Custom sphere and difficulty cards can be created.

Card templates designed to be uploaded directly to PrinterStudio. Users can "cut" the card with a button.

 

Coments and bugs are welcome.



#3 Hannibal_pjv

Hannibal_pjv

    Member

  • Members
  • 157 posts

Posted 18 June 2013 - 11:18 AM

Nice to see LOTR to get past Strange eons 2.x. Are there golden icons for easy mode cards? Or templates for own nighmare versions? They would be cool. Have to play with this version so I can compare it to 2.3.

 



#4 Raven1015

Raven1015

    Member

  • Members
  • 434 posts

Posted 18 June 2013 - 06:13 PM

Still has the bug on Macs where formatting (bold, italic, underline) doesn't work. Not sure if that can be fixed or not.


Check out my LOTR LCG blog: talesfromthecards.wordpress.com

Listen to The Grey Company podcast: greycompanypodcast.wordpress.com


#5 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 18 June 2013 - 08:10 PM

Easy ring is included, but without the real thing in hands not much can be done, and something similar was done. Also, Nightmare templates will be included when I can get my hands on them.

The Mac bug seems to be a Strange Eons problem. Does it happen with other games? You should coment it in the SE forums.



#6 Thelric

Thelric

    Member

  • Members
  • 251 posts

Posted 23 June 2013 - 06:15 PM

Raven1015 said:

Still has the bug on Macs where formatting (bold, italic, underline) doesn't work. Not sure if that can be fixed or not.

If you mean the issue where on Macs fonts included with a plug-in don't get made into a family properly, so applying bold/italic doesn't use the bold/italic versions of the font (that are also included in the plug-in):

Based on my testing, that has been resolved since the build of SE that switched from requiring Java 6 to the one requiring Java 7. I think it was the one released around the start of April. The problem was due to a bug in Apple's implementation of Java 6. I reported it to them, but nothing ever happened with it. (As is typically the case with Apple, there is no way to know if anyone even looked at it, let alone tried to fix it.) With Java 7, Apple's font library isn't being used anymore, so the problem solved itself. This was actually one of the main reasons I decided to require Java 7.

If you mean some other problem with bold/italic, I'm not sure what you mean. You'll have to provide more information.

By the way, over the last couple of months a lot of OS X-specific issues have been resolved. If you haven't updated SE3 lately, it'd be a good idea to do so. If in doubt about whether to bother updating, you can check the Twitter feed (@StrangeEons) to get a quick summary of the most important changes. There are usually 1 or 2 updates a month.

Cheers,
Chris



#7 Raven1015

Raven1015

    Member

  • Members
  • 434 posts

Posted 23 June 2013 - 07:33 PM

Thelric said:

Raven1015 said:

 

Still has the bug on Macs where formatting (bold, italic, underline) doesn't work. Not sure if that can be fixed or not.

 

 

If you mean the issue where on Macs fonts included with a plug-in don't get made into a family properly, so applying bold/italic doesn't use the bold/italic versions of the font (that are also included in the plug-in):

Based on my testing, that has been resolved since the build of SE that switched from requiring Java 6 to the one requiring Java 7. I think it was the one released around the start of April. The problem was due to a bug in Apple's implementation of Java 6. I reported it to them, but nothing ever happened with it. (As is typically the case with Apple, there is no way to know if anyone even looked at it, let alone tried to fix it.) With Java 7, Apple's font library isn't being used anymore, so the problem solved itself. This was actually one of the main reasons I decided to require Java 7.

If you mean some other problem with bold/italic, I'm not sure what you mean. You'll have to provide more information.

By the way, over the last couple of months a lot of OS X-specific issues have been resolved. If you haven't updated SE3 lately, it'd be a good idea to do so. If in doubt about whether to bother updating, you can check the Twitter feed (@StrangeEons) to get a quick summary of the most important changes. There are usually 1 or 2 updates a month.

Cheers,
Chris

 

Thanks for the thorough reply. I'll have to do some testing, and make sure I have everything set up the way it needs to be. Basically, the issue is that the bold and italic functions don't work, and they don't register on the actual card. I'll check it out though, and make sure that I'm not doing something wrong on my end.


Check out my LOTR LCG blog: talesfromthecards.wordpress.com

Listen to The Grey Company podcast: greycompanypodcast.wordpress.com


#8 Raven1015

Raven1015

    Member

  • Members
  • 434 posts

Posted 23 June 2013 - 07:41 PM

Not sure what I did, but it looks like the issue was just that it didn't update to SE3 correctly. Anyway, it's working perfectly now, and I'm loving the new version!


Check out my LOTR LCG blog: talesfromthecards.wordpress.com

Listen to The Grey Company podcast: greycompanypodcast.wordpress.com


#9 Memetix

Memetix

    Member

  • Members
  • 439 posts

Posted 23 June 2013 - 09:00 PM

I'm looking to upgrade to the new release however I can't seem to load my old (strange eons 2) files into the new version.

I get a warning that arkham.sheet.CharacterSheet.$DeckSnappingHintClass is missing. Any ideas how to get around this issue?



#10 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 24 June 2013 - 08:34 AM

Memetix said:

I'm looking to upgrade to the new release however I can't seem to load my old (strange eons 2) files into the new version.

I get a warning that arkham.sheet.CharacterSheet.$DeckSnappingHintClass is missing. Any ideas how to get around this issue?

Both versions of the plugins are incompatible because they are very different. Now you have 2 options:

  1. Keep using Strange Eons 2 untill you finish your card set. I checked that the old plugin's compatibility with Strange Eons 3 has been lost..
  2. Update your cards manually to the new plugin. Strange Eons 2 has the Picture Thief plugin that let's you get the portraits from your cards' files. That and copying the text to notepad should be enough to update the cards rapidly.


#11 Memetix

Memetix

    Member

  • Members
  • 439 posts

Posted 25 June 2013 - 12:40 AM

avergonzado_triste



#12 Ranwyr

Ranwyr

    Member

  • Members
  • 6 posts

Posted 29 July 2013 - 02:48 PM

I suppose I have a compability problem when I use your tool and install some other plugins.

My cards show no name, no values for Attack, defense, quest, cost, hit Points etc.

 

If I use any of the tags like <will> or <lea> the text dissapears at a certain point, starting with the position where the icon should have appeared. In this case the text box also gets completly surrounded by a red dotted line as if I entered too much text.

 

I know this is rather vague, and as nobody else seems to have this problemit is probably not very high on your priority list. But if I can assist you in any way with this, please contact me.

 

p.s.: I loved the fix in the last version, where there was a Problem with the Arkham and LOTR ally Cards :)



#13 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 30 July 2013 - 03:57 AM

Beta 2 WIP

Work-In-Progress versions are for people that love the thrill of losing previous work. I advise you: Before using your cards created with beta 1, make a backup of your cards to avoid painfull loses!

This version has known problems. Use it only for testing purposes.

 

Important changes for users

  • Beta1 cards should load properly, but I haven't tested it as much as I wanted. If you open a beta 1 card that uses something not found in the instalation, like an official Encounter Set icon, a message will appear telling what's missing. If you save the card at this moment, you'll lose your original work. Also, I remind you that this version is incompatible with the old Strange Eons 2 version of the plugin.
  • Now, tag buttons can be found in the context bar. You can add the buttons through the Preferences>Context Bar menu.
  • LotR category in New menu has dissapeared, and cards are distributed though the regular categories. You can filter LotR cards with the selector in the upper-right corner.
  • Card stats' rendering and some templates have been changed to make it more consistent between versions and pretier (and it will change just a bit more in beta3). If you are working on a card set, you should keep using beta1 untill you finish your card set to make sure you've got them all looking similar. Then, you can make a backup of your cards and try loading them with this beta2.

Instalation

This version won't be available in the Strange Eons catalogue untill is tested. It must be installed manually. Here you can find it: http://www.4shared.c...xWZRBW/WIP.html

 

I've changed how the plugin is distributed, to make it easier to maintain. Now there are 7 packages instead of 2:

  • The plugin, containing Core Set components and spheres: TheLordOfTheRingsLCG.seext
  • Additional components appeared later (Objective Ally, Treasure and 3 accesory): TheLordOfTheRingsLCG-P.seext
  • Addtional sphere and difficulty variants (Baggins, Easy and customs): TheLordOfTheRingsLCG-V.seext. Note that the Easy circle is just something similar and may not look the same as the official cards.

  • Addtional official Encounter Set and Collection icons: TheLordOfTheRingsLCG-I.seext

  • 3 high definition add-ons.

 

Only the main plug-in is required to create cards, but you may need to install the P, V and I packages to keep compability with cards created with beta 1. The HD packages are recomended only for printing. The easiest way to install these packages is to unpack the ZIP file and open the seext files through StrangeEons' File menu.

 

 

 

 

 

I suppose I have a compability problem when I use your tool and install some other plugins.

My cards show no name, no values for Attack, defense, quest, cost, hit Points etc.

 

If I use any of the tags like <will> or <lea> the text dissapears at a certain point, starting with the position where the icon should have appeared. In this case the text box also gets completly surrounded by a red dotted line as if I entered too much text.

 

I know this is rather vague, and as nobody else seems to have this problemit is probably not very high on your priority list. But if I can assist you in any way with this, please contact me.

 

p.s.: I loved the fix in the last version, where there was a Problem with the Arkham and LOTR ally Cards :)

 

I've also seen the problem with the tags. I hope it's fixed in this version for everyone, because the problem seems a bit random (seems a mixture of a bad font file and SE version changes and who knows what more). If you have the plugin opened as a project (that is, like you were be developing it) and also have it installed normally, you may see this problem.

 

For the compatibility problem, if it persists, tell me wich plugins you have installed, SE version and operative sistem you are using.

 

I'll be on vacation for 2 weeks. And I couldn't test this version as much as needed to release it. Please, when you test it a few days (mostly saving and loading cards), tell me the result so I can tell Chris (Strange Eons' creator) to upload it to the catalogue.


Edited by karagh, 07 August 2013 - 04:21 AM.


#14 Ranwyr

Ranwyr

    Member

  • Members
  • 6 posts

Posted 30 July 2013 - 01:37 PM

Thanks for the realy fast reply. I istalled the 7 packages. All Icons, stats etc seem to display normaly. I have not encountered any heavy side effects yet. I have one minor error though:

Whenever I load a previously saved card for the first time or if I change the portrait, I get this error:

Uncaught TypeError: Cannot call method "setImage" of undefined
 at res:TheLordOfTheRingsLCG/diy/library.js:316 (drawImages)
 at res:TheLordOfTheRingsLCG/diy/library.js:640 (paintFront)
 

This has no negative effect however, the card looks fine and saves and behaves normaly.

 

Oh and finaly: Have a nice trip :) I will be creating some more Cards in the next days and post my findings.


Edited by Ranwyr, 30 July 2013 - 02:01 PM.


#15 Ranwyr

Ranwyr

    Member

  • Members
  • 6 posts

Posted 04 August 2013 - 05:14 AM

Beta 2 WIP Error Report

The portrait problem mentioned in my last post seems to be connected to the thumbnail in the properties section. It does not appear when I load a card, but when I simply select it for the first time.

 

Tags are not always displayed correctly. They simply do not appear on the card. This time however the area to the left of the Portrait containig name, cost, defense, hit points etc. is not affected, and the rules text does not simply stop where the tag should be displayed.

 

If I use the shadow section or the shadow tag, the red dotted box appears and all the rules text is displayed in one line. The shadow and flavour text do not appear on the card at all.

 

The last two problems are acting strangly. They appeared after 3 days of using the plugin without any incident. It began as I had about 12 cards open at the same time. First the threat tag acted up, all the other stuff was normal. Attack, defense, all the other tags were displayed as they should be. Then the problem with the shadow text came along, and after that all the tags went mising.

When I create a new game component it is instantly affected by this.

Restarting the apllication or the PC has no effect.

 

System used: Windows 8, Strange eons 3 x64-b3693, Arkham Horror plugin installed

I will try this again with the Strange Eons  3 x32 in the next days.


  • karagh likes this

#16 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 07 August 2013 - 04:21 AM

Beta 2 WIP Error Report

Thank you for the test. :)

It seems definitelly the font file won't work properly depending on the renderer. Most problems are related to the font file. The problem is that I included the Shadow effect icon in the font file. It must be breaking the renderer because it's a weird glyph (much bigger than a letter or Spirit icon). Next week, I'll remove the Shadow effect icon from the font and include it as an image. That should do the trick.

The setImage error is easy to resolve.



#17 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 16 August 2013 - 05:01 AM

Updated the WIP version (hopefully) correcting previous problems.



#18 Ranwyr

Ranwyr

    Member

  • Members
  • 6 posts

Posted 17 August 2013 - 06:40 AM

My Cards from the last WIP Version are all fried (was to be expected), but when I create some new cards it works just fine. No error thus far.



#19 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 17 August 2013 - 08:47 AM

Thank you. If the problem with the text box is corrected I'll upload the new version to the catalogue in a few days.



#20 karagh

karagh

    Member

  • Members
  • 131 posts

Posted 24 December 2013 - 05:08 AM

The Lord of the Rings LCG plugin for Strange Eons beta 3 (christmas edition) released

The new version of the plugin is now available here: http://www.4shared.c...heRingsLCG.html. To install it manually, just open the all the seext with Strange Eons and restart it. You also NEED to update Strange Eons. Not yet available in the Strange Eons repository.

  • New components and variants: Campaign card, Boon and Burden. Function is done, but the template images right now are of pretty low quality. Should be updated to something nice soon.
  • Help added in form of tip buttons.
  • Uniqueness button. No need to include tags in the name field.
  • Keyword field added.
  • Collection info field added.
  • Icons updated up to The Black Riders.
  • Change default copyright and collection info text in preferences.
  • Option to show or not advanced controls (tints and some texts)
  • Custom bleed margin was removed. Strange Eons has it's own system to add synthetic bleed margin to components. You can use it when in the window opened when exporting or in the deck options.

When loading components from previous versions, check portraits centering. Custom Sphere template has changed too, and can change more it's colour, old designs will look different but lowering the brightness should make them look the same. Also if you added more text than the number to the Collection Number field, you should move it to Collection Info field to show it properly.

If you find any problem (like when loading old components), please report it.

Anyone willing to translate the plugin to their own languaje contact me through private message.
 


Edited by karagh, 28 December 2013 - 07:53 AM.

  • Raven1015 likes this




© 2013 Fantasy Flight Publishing, Inc. Fantasy Flight Games and the FFG logo are ® of Fantasy Flight Publishing, Inc.  All rights reserved.
Privacy Policy | Terms of Use | Contact | User Support | Rules Questions | Help | RSS