Jump to content



Photo

Phantom DOA


  • Please log in to reply
13 replies to this topic

#1 TheWanderingMiller

TheWanderingMiller

    Member

  • Members
  • 196 posts

Posted 09 July 2014 - 10:16 PM

I was opening a brand new TIE Phantom when I ran into a bit of trouble.  No, it did not sudden vanish before my eyes…

 

I was having a hard time mounting it to when I realized there was something preventing the peg from going in.  Upon further inspection I think a peg broke off inside the ship's connector.  But the pegs that came with it are still pristine, so it wasn't me.  I guess my Phantom just came this way.

 

Has anyone else experienced this problem with one of their ships?  I was also wondering how this happened.  Do you think FFG test fits the pegs and out of careless this one broke off?

I don't really see an easy way to dig out the broken piece so unless someone has an idea I'm going to contact FFG for a new ship.



#2 Rakky Wistol

Rakky Wistol

    The Grey

  • Members
  • 2,838 posts

Posted 09 July 2014 - 10:18 PM

Contact FFG customer service.  They will hook you up.  They're great about fixing broken product. 



#3 KommanderKeldoth

KommanderKeldoth

    Member

  • Members
  • 189 posts

Posted 09 July 2014 - 10:23 PM

You could always pull out the whole peg (female and male piece) from the model, cut one of your extra pegs in half and then glue the female half to your model to create a new mounting.

 

That's how I turned by B-wings sideways when one of their mounting pegs broke



#4 DR4CO

DR4CO

    Member

  • Members
  • 448 posts

Posted 09 July 2014 - 10:29 PM

I don't really see an easy way to dig out the broken piece so unless someone has an idea I'm going to contact FFG for a new ship.

 

I haven't been able to try it yet (meeting up with a friend who has the tools tomorrow), but after doing the same thing to one of my Bombers I got this suggestion from atr127:

 

use a very thin drill bit to drill into the remaining part of the peg.  then get a thin piece of wire or a pin, place a tiny dab of glue on it and stick it in the hole.  wait for it to dry and pull it out.  As the meercat says 'simples'. 

 

The logic seems sound, and it should only take a few minutes (and however long the glue needs to dry, of course).


Edited by DR4CO, 09 July 2014 - 10:31 PM.

The Fleet

6 X-wings - 3 Y-wings - 6 A-wings - 4 B-wings - 3 E-wings - 4 Z-95s - 1 HWK-290 - 2 YT-1300s - 1 Transport - 1 CR-90

5 TIE Fighters - 6 TIE Interceptors -  2 TIE Advanceds - 3 TIE Bombers - 2 TIE Defenders - 2 TIE Phantoms - 2 Firespray - 2 Shuttles


#5 gundamv

gundamv

    Member

  • Members
  • 344 posts

Posted 09 July 2014 - 10:33 PM

What's the replacement process like?  Do they send you a completely new unit or just the defective piece (in this case, the Phantom figure itself)?  Are there hoops you need to jump through to get a replacement unit?



#6 executor

executor

    Member

  • Members
  • 482 posts

Posted 09 July 2014 - 10:59 PM

take a safety pin, heat it up with a lighter and when it's red hot stick it into the piece that's broken off in the peg

 

wait for it to cool (about 10-15 sec) and pull it out.. simple, easy, you're welcome :)


Current Fleet

Rebellion: 5 X-wings, 4 Y-wings, 5 A-wings, 3 B-wings, 1 HWK-290, 2 YT-1300's, 2 E-wings, 1 Z-95, 1 Rebel Transport, 1 CR-90

Empire: 8 Tie Fighters, 2 Tie Advanced, 9 Tie Interceptors, 3 Tie Bombers, 1 Lambda Shuttle, 3 Firespray 31's, 2 Tie Phantoms, 2 Tie Defenders


#7 oneway

oneway

    Imperial Bomber Pilot

  • Members
  • 2,606 posts

Posted 09 July 2014 - 11:28 PM

or snap off the peg in the model and drill a 3mm hole about a 1/16th inch deep and glue in a 3mm rare earth magnet, then mount a magnet on the peg to the stand and then let them dry.. no pesky peg out the bottom anymore and a ship that turns if you want it to.. or use a ring magnet and a ball bearing.. and you get fancy angles and stuff.. lol.. I have a couple of each for grins.. 


"I mean, come on kid, my armor's older than you are.."

"Hahaha. Very funny, at least I only hit the enemy target, Ya collateral bastard."

Corp. Haig Talin, MK - 472

Armor 18 - Fire - N - Ice 181st Mechanized Armor Assault Div


#8 Qapla187

Qapla187

    Member

  • Members
  • 306 posts

Posted 10 July 2014 - 01:07 AM

I used a good old hobby knife to get it out when I broke one in a HWK. I take no responsibility for ER visits if you try it and end up painting your Phantom red. Just leave it on, it'll go fasta that way!

Hmm a red Phantom. That could look interesting.
:>¡<: X-wing x6, Y-wing x3, TIE Fighter x6, TIE Advanced x3, A-wing x4, YT-1300 x2, TIE Interceptor x9,
Firespray-31 x3, B-wing x4, HWK-290 x2, TIE Bomber x6, Lambda Shuttle x2, E-wing x3, Z-95 x4, TIE Defender x3, TIE Phantom x2, GR-75 x2, CR-90 x1

Perish quickly you will, if without Push, an A-wing you fly.

#9 Caliber42

Caliber42

    Member

  • Members
  • 117 posts

Posted 10 July 2014 - 04:15 AM

FFG has by far THE best customer service of any gaming company I personally have ever had to contact. I have broken two pegs, both my own fault, and when I asked regarding purchasing replacements they sent me a small baggie of 2-3 sets at no charge to me.

 

All I did was follow the links, fill in the blanks, upload a pic, and within 24hrs they sent me an email stating they were shipped.

 

I wish other companies were as awesome...

 

-Cal



#10 TheWanderingMiller

TheWanderingMiller

    Member

  • Members
  • 196 posts

Posted 10 July 2014 - 11:19 AM

Thanks everyone.  I went ahead and filled a request and was surprised when it got denied.  Supposedly I need to add a photo to my request.

 

I actually tried this when I originally submitted the request, but I didn't have any luck capture the issue at hand.  The level of zoom needed might be more than my iPhone can handle.  Not thinking that the picture would be of any use I didn't submit it.  I guess I'll try again later tonight.



#11 Cptnhalfbeard

Cptnhalfbeard

    Member

  • Members
  • 556 posts

Posted 10 July 2014 - 11:23 AM

When a bit of peg broke off in one of my ships I used this method:

Take a pin or needle and heat the tip of it with a lighter until it is red hot. (Be careful not to burn yourself the pin/needle will get hot too)
Push the pin/ needle firmly into the broken part of the peg
Wait a few seconds for the plastic/pin to cool.
Pull the pin/needle out quickly.
Repeat if necessary.

Worked like a charm for me :)

#12 Rodrigo Istalindir

Rodrigo Istalindir

    Member

  • Members
  • 75 posts

Posted 10 July 2014 - 11:24 AM

Had the same thing with my second Firespray.  FFG Customer Service hooked me right up.  Filled out the form with a picture, had the replacement in a week.



#13 PhantomFO

PhantomFO

    Member

  • Members
  • 594 posts

Posted 10 July 2014 - 11:30 AM

Thanks everyone.  I went ahead and filled a request and was surprised when it got denied.  Supposedly I need to add a photo to my request.
 
I actually tried this when I originally submitted the request, but I didn't have any luck capture the issue at hand.  The level of zoom needed might be more than my iPhone can handle.  Not thinking that the picture would be of any use I didn't submit it.  I guess I'll try again later tonight.

When I had a similar problem with an Interceptor, my iPhone canera was more than sufficient.
REBEL: 3 X-Wings, 2 B-Wings, 1 Y-Wing, 1 A-Wing, 1 E-Wing, 2 Z95 Headhunters, 1 YT-1300, 1 HWK-290
IMPERIAL: 5 TIE Fighters, 3 TIE Interceptors, 1 TIE Bomber, 1 TIE Phantom, 1 TIE Defender, 1 TIE Advanced, 1 Lambda, 1 Firespray

#14 Nickotine42

Nickotine42

    Member

  • Members
  • 313 posts

Posted 10 July 2014 - 11:51 AM

I knew the phantom was broken.
  • What likes this




© 2013 Fantasy Flight Publishing, Inc. Fantasy Flight Games and the FFG logo are ® of Fantasy Flight Publishing, Inc.  All rights reserved.
Privacy Policy | Terms of Use | Contact | User Support | Rules Questions | Help | RSS