Jump to content



Photo

WFRP Maptools: How and where do I load the campaign template?


  • Please log in to reply
11 replies to this topic

#1 Noelyuk

Noelyuk

    Member

  • Members
  • 9 posts

Posted 03 July 2014 - 08:43 AM

Hi there

 

I have downloaded Maptools but so far have had no success in installing the WFRP content from Gritzman's Gallery. 

 

I read somewhere that the campaign template .cmpgn file should be copied to a .maptools folder/campaign thumbs or something similar but I can find no sign of any such folders on my computer which I should perhaps point out is mac osx.

 

When I went ahead and tried to navigate and open the downloaded campaigns I simply get the following error message: 

 

24l699x.jpg

 

What am I doing wrong? Can someone please clarify? It's driving me nuts. 

 

Cheers

Noely



#2 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 03 July 2014 - 09:12 AM

Try an older version of maptool.  I think I ran on 68.

 

Also, be sure to unzip the campaign files.

 

Lastly, cross your fingers :)  

 

You can always ask at:  http://ffgvirtualrpg.prediger.at/

 

jh


Edited by Emirikol, 03 July 2014 - 09:13 AM.


#3 Noelyuk

Noelyuk

    Member

  • Members
  • 9 posts

Posted 05 July 2014 - 04:48 AM

No luck i'm afraid Emirikol

 

I tried several earlier versions including the one you mentiioned 68 but with no joy. 

 

I'm sure there is a step I am missing (copying the template to somewhere within maptools) but on mac osx I'm not exactly how to do this and where to copy it.

 

Trying to simply Open Campaign gets me the error message I posted above. If I attempt to unzip the campaign files I get a message saying the file is incomplete. But having downloaded several versions from Gitzman's Gallery I'm not convinced they can all be corrupt.

 

Help!! I'm running out of ideas.

 

OH and thanks to everyone in advance for your help



#4 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 05 July 2014 - 09:28 AM

Here, I found one that works:

 

Use version b.87

 

Use the campaign file in post 1 (his link is called "map")

http://community.fan...alse-pretenses/

 

[EDIT:  ALSO INCREASE YOUR STACK SIZES:

maxmem 1024

minmem 128

stack size 5

 

 

 

Best of luck,

 

jh


Edited by Emirikol, 05 July 2014 - 09:41 AM.


#5 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 05 July 2014 - 09:56 AM

I also saw this framework:  http://www.alchimiste.biz/wa/WFRP/   I haven't tried it, but it seems interesting.

 

I would also advise you to check out the Prediger site and look at the maptool play thread(s):  http://ffgvirtualrpg.prediger.at/

 

jh


Edited by Emirikol, 05 July 2014 - 09:59 AM.


#6 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 05 July 2014 - 11:47 AM

I've tested this several times now:

I can work the "False Pretenses" campaign file all the way up to 1.3b89.

 

I cannot get the Alchemiste framework to work on 86, 87 or 89 (regular version of maptool..not mac/os).  I get the same error as you.  it says that it was tested to b87, but I can't get that to work.

 

Notice that on the downloads page there is a mac/os download and a regular download (you probably already knew that).

 

The Gitzman campaigns work on b86.

 

jh



#7 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 05 July 2014 - 06:15 PM

Finally!  I got a full download from the http://www.alchimiste.biz/wa/WFRP.  The campaign file is 41 mb.  My original download was only 21.  It works with b89.

 

Now I'm gettting a "Stack overflow" error with b87 and b89.

 

jh


Edited by Emirikol, 08 July 2014 - 11:00 AM.


#8 Eradico Pravus

Eradico Pravus

    Member

  • Members
  • 242 posts

Posted 05 July 2014 - 06:27 PM

Noelyuk,

 

Frustrating!

 

I am a maptools neophyte. However: once I downloaded a couple of versions I ran into problems with opening existing campaigns too. You are probably doing this but make sure if you make changes then you save and open with the same version. I went to b89 and had troubles with my b87 files.

 

I can't even use my "MapToolLauncher" application. I have to open my maptools folder, double-click "maptool-1.3.b87" Executable Jar File to launch the program. From there I am able to access old campaigns and various image folders.

 

This post isn't much help but you at least have my sympathy! :)



#9 Noelyuk

Noelyuk

    Member

  • Members
  • 9 posts

Posted 06 July 2014 - 08:58 PM

Guys 

 

Thanks again for your help. But none of the things have worked so far. Unless there's something missing prior to trying to open a campaign then I simply don't know what the issue is. 

 

Emirikol as per your suggestion I am using b87 and yes it's the mac.dmg version :) 

 

Mapools is open and seemingly letting me create content but nothing whatsoever will load when I navigate to the .cmpgn files via Open Campaign option. 

 

Can someone clarify: Is there something I should be doing with the campaign template file BEFORE attempting to open these campaign tools through maptools? 

 

I'm not someone who usually gives up but my patience is being severely tested and I'm not far away from at least for the time being focussing my efforts on Fantasy Grounds which at the very least works for me.

 

Perhaps I can return to Maptools later (once i've taken a few deep breaths and counted to 1,000) 

 

PS Oh and as for stack sizes I think that's a techy step over my head (not hard). I did find an info.plist file containing the data for stacks etc but the doc was locked as read only and therefore I wasn't able to make any changes. 


Edited by Noelyuk, 06 July 2014 - 09:31 PM.


#10 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 07 July 2014 - 01:12 PM

No, there's nothing to do to the .cmpgn file.  You probably cannot open it b/c it wasn't created on a Mac/OS. You could try an emulator (computer science anyone?)

 

Stack sizes:  when maptool opens, there should be a box that asks how much memory and "stack" you want to use.  from my testing, it hasn't made a lot of difference.

 

I've just settled on the False Pretenses .cmpgn file at b89 and will just recreate macros as necessary (I don't really use them much anyways as I assume players can handle that on their paper copies of their characters at home.).

 

The only thing that I really needed was the dice roller box.  Can you at least get one of those to work?

 

jh


Edited by Emirikol, 07 July 2014 - 01:15 PM.


#11 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 08 July 2014 - 11:07 AM

If you're using Java7, the maptool.exe file is just to set your memory and stack limits (but it can't auto-launch Maptools).  The .jar file is the actual program you need to double-click on.  It still works fine.  I'd recommend porting over your old stuff to the new framework.

 

I'm running it on Java 7 and have uploaded the working dicebox b89 framework for DOS:  http://forums.rptool...=253371#p253371

 

Seems to be working fine now.

 

The stack limits seem to work best up to 10.


Edited by Emirikol, 08 July 2014 - 11:17 AM.


#12 Emirikol

Emirikol

    ~Ĉiam subskribi antaŭ-nup kun Fimir

  • Members
  • 5,084 posts

Posted 08 July 2014 - 11:56 AM

For the newbies out there, here's the tutorial:  http://forums.rptool...=252549#p252549

 

Here's a working pic:

Image2.jpg


Edited by Emirikol, 08 July 2014 - 11:57 AM.





© 2013 Fantasy Flight Publishing, Inc. Fantasy Flight Games and the FFG logo are ® of Fantasy Flight Publishing, Inc.  All rights reserved.
Privacy Policy | Terms of Use | Contact | User Support | Rules Questions | Help | RSS